impala-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe McDonnell (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (IMPALA-5324) Fix version check in EvalDictionaryFilters
Date Fri, 26 May 2017 00:18:04 GMT

     [ https://issues.apache.org/jira/browse/IMPALA-5324?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joe McDonnell resolved IMPALA-5324.
-----------------------------------
       Resolution: Fixed
    Fix Version/s: Impala 2.9.0

commit a173f70a0ccacff2de978d171d6bb42349917471
Author: Joe McDonnell <joemcdonnell@cloudera.com>
Date:   Tue May 23 16:00:55 2017 -0700

    IMPALA-5324: Fix version check in EvalDictionaryFilters
    
    Due to a bootstrapping issue with the dictionary
    filtering code change, the parquet version check used in
    EvalDictionaryFilters was checking for < 2.10. However,
    the impala 2.9 parquet contains the appropriate encoding,
    so this changes the version check to be < 2.9.
    
    Change-Id: Icc216332171038f74ff1d2ce3066da8167095361
    Reviewed-on: http://gerrit.cloudera.org:8080/6969
    Reviewed-by: Alex Behm <alex.behm@cloudera.com>
    Tested-by: Impala Public Jenkins


> Fix version check in EvalDictionaryFilters
> ------------------------------------------
>
>                 Key: IMPALA-5324
>                 URL: https://issues.apache.org/jira/browse/IMPALA-5324
>             Project: IMPALA
>          Issue Type: Bug
>          Components: Backend
>    Affects Versions: Impala 2.9.0
>            Reporter: Joe McDonnell
>            Assignee: Joe McDonnell
>             Fix For: Impala 2.9.0
>
>
> The code in EvalDictionaryFilters needs to check for version below 2.9, not 2.10. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message