impala-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Apple (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IMPALA-160) Impala crashes on startup on AMD machines without ssse3 support.
Date Thu, 16 Mar 2017 03:42:41 GMT

     [ https://issues.apache.org/jira/browse/IMPALA-160?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jim Apple updated IMPALA-160:
-----------------------------
    Attachment: inspector_output_705.json
                hs_err_pid7505.log

> Impala crashes on startup on AMD machines without ssse3 support.
> ----------------------------------------------------------------
>
>                 Key: IMPALA-160
>                 URL: https://issues.apache.org/jira/browse/IMPALA-160
>             Project: IMPALA
>          Issue Type: Bug
>    Affects Versions: Impala 0.6
>         Environment: IMPALA 0.6-1.p0.109, CDH 4.2.0-1.cdh4.2.0.p0.10 on Ubuntu 12.04.2
LTS, Hadoop cluster created with Cloudera Manager free 4.5.0 using parcels
>            Reporter: Vladimir Nicolici
>            Assignee: Nong Li
>              Labels: SIGILL, crash, impala
>             Fix For: Impala 1.2.1
>
>         Attachments: 344-impala-IMPALAD.tar.gz, hs_err_pid7505.log, hs_err_pid7505.log,
hs_err_pid7505.log, inspector_output_705.json
>
>
> When attempting to create a Cloudera Hadoop cluster including Impala, or when attempting
to add an Impala service to an existing cluster, the operation fails with this error:
> Service did not start successfully; not all of the required roles started: No Impalads
are running.
> The beginning of stdout for each impalad instance shows the error that causes the crash:
> \# A fatal error has been detected by the Java Runtime Environment:
> \#
> \#  SIGILL (0x4) at pc=0x00000000006a22ca, pid=11285, tid=140297147213632
> \#
> \# JRE version: 6.0_31-b04
> \# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.6-b01 mixed mode linux-amd64 compressed
oops)
> \# Problematic frame:
> \# C  [impalad+0x2a22ca]  boost::uuids::detail::sha1::process_block()+0xda
> \#
> \# An error report file with more information is saved as:
> \# /run/cloudera-scm-agent/process/342-impala-IMPALAD/hs_err_pid11285.log
> \#
> \# If you would like to submit a bug report, please visit:
> \#   http://java.sun.com/webapps/bugreport/crash.jsp
> \# The crash happened outside the Java Virtual Machine in native code.
> \# See problematic frame for where to report the bug.
> The strange thing is I previously installed two other test clusters using the same software
stack and architecture, and I didn't hit this problem.
> But in this case, I even formatted the hosts and reinstalled everything including the
OS, and I hit the same problem again.
> I attached the directory with the logs and the inspector output for the cluster.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message