impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sky <x_h...@163.com>
Subject Re:Re: libTestUtil.so: cannot open shared object file
Date Thu, 21 Dec 2017 09:15:57 GMT
Thanks,
    I found it in the place before moved  according "ldd",  but the libTestUtil.so is hard
code? I can not move the IMAPLA_HOME dir?








At 2017-12-21 00:47:12, "Philip Zeyliger" <philip@cloudera.com> wrote:
>You can use “ldd” or LD_DEBUG=all to see how the dynamic linker is looking
>for things. Chances are it’s not looking in the right place after you moved
>things!
>
>P
>
>On Wed, Dec 20, 2017 at 3:10 AM Jin Chul Kim <jinchul@gmail.com> wrote:
>
>> Hi,
>>
>> You may need to narrow down this build problem. I guess you need to check
>> the followings:
>> 1. Check your disk space. Do you have free space? (e.g. df -h)
>> 2. Check permission. Try to create a file (e.g.
>> touch be/build/release/testutil/libTestUtil.so)
>> 3. Check build history because there was an error to compile a .cc before
>> linking
>>
>> Regarding the third case, you can check it with the following command:
>> cd be/src/testutil; cmake .; make TestUtil
>>
>> Best regards,
>> Jinchul
>>
>> 2017-12-20 19:22 GMT+09:00 sky <x_hsky@163.com>:
>>
>> > Hi all,
>> > I compiled the Impala on the /data directory on a machine and moved to
>> the
>> > /dreambase/impala/impala directory of the other machine,prompted the
>> > following errors:
>> >  # ./bin/start-statestored.sh
>> > /home/impala/impala/be/build/latest/statestore/statestored: error while
>> > loading shared libraries: libTestUtil.so: cannot open shared object file:
>> > No such file or directory
>> >
>> >
>> > And the location of this file is "./be/build/release/testutil/
>> > libTestUtil.so".
>> >
>> >
>>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message