impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Robinson <he...@apache.org>
Subject Re: Problem running Impala built with dynamic linking
Date Thu, 20 Jul 2017 00:01:52 GMT
Yep, you need to remove the downloaded version of gflags and replace it
with a recent toolchain version. See my mail from yesterday for
instructions:
https://lists.apache.org/api/source.lua/a154f43ef76e3da1271efed2740d447bbaeca09509156c7b728f2dd0@%3Cdev.impala.apache.org%3E

On 19 July 2017 at 16:56, Bikramjeet Vig <bikramjeet.vig@cloudera.com>
wrote:

> After fetching latest from asf-gerrit (that has the toolchain commit
> related to gflags) and doing a manual toolchain refresh, I am unable to run
> impala when I build with "make_debug" or "buildall -so", both statestore
> and catalogd show the following error:
>
> ERROR: something wrong with flag 'flagfile' in file
> '/data/jenkins/workspace/verify-impala-toolchain-package-build/label/ec2-
> package-ubuntu-16-04/toolchain/source/gflags/
> gflags-2.2.0-p1/src/gflags.cc'.
> One possibility: file
> '/data/jenkins/workspace/verify-impala-toolchain-package-build/label/ec2-
> package-ubuntu-16-04/toolchain/source/gflags/
> gflags-2.2.0-p1/src/gflags.cc'
> is being linked both statically and dynamically into this executable.
>
> I am only able to make it work if I go with static linking by building it
> with "buildall" without the "-so"
>
> Anyone facing the same issue?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message