impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Wood <tw...@cloudera.com>
Subject Re: Build failure: FlagRegisterer not found by linker
Date Mon, 22 May 2017 21:57:41 GMT
All fixed, thanks!
TW

On Mon, May 22, 2017 at 1:54 PM, Henry Robinson <henry@apache.org> wrote:

> You need to remove $IMPALA_TOOLCHAIN/glog-0.3.4-p2, then run
> bin/bootstrap_toolchain.py again. Make sure you've sourced impala-config.sh
> to get the toolchain version bumped up as well.
>
> On 22 May 2017 at 13:41, Timothy Wood <twood@cloudera.com> wrote:
>
>> Please excuse, in advance, my naivete, inexperience, off-topicness, etc.
>> :)
>>
>> I'm having trouble completing a build of Impala.  The linker fails to
>> build the tests (atomic-test, instruction-counter-test &c.) with several
>> reports of:
>> ../../../toolchain/glog-0.3.4-p2/lib/libglog.a(libglog_la-logging.o):logging.cc:function
>> _GLOBAL__sub_I_logging.cc: error: undefined reference to
>> 'google::FlagRegisterer::FlagRegisterer<bool>(char const*, char const*,
>> char const*, bool*, bool*)'
>>
>> I Googled references to ...FlagRegisterer and found postings about this
>> problem; some recommended checking that gflags was built and available.  I
>> found that I have two gflag versions (2.2.0, 2.2.0-p1) in my loader search
>> path.  I tried moving one and then the other out of the way and rebuilding
>> each time, but I get the same errors in all cases.  I'm not sure what to
>> try next to resolve this dependency.
>>
>> Thanks,
>> TW
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message