impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Volker ...@cloudera.com>
Subject Re: Kudu errors when using a custom toolchain
Date Tue, 28 Mar 2017 20:30:50 GMT
Cool, thanks! That (and re-sourcing the impala config) seems to have done
the trick.

On Tue, Mar 28, 2017 at 6:30 PM, Tim Armstrong <tarmstrong@cloudera.com>
wrote:

> I think the distcc_env.sh script went rogues and deleted all the *cmake*
> files under your toolchain. I'd suggest blowing away Kudu in the toolchain
> and bootstrapping again.
> We fixed clean.sh to not do that a while ago but I just noticed that the
> distcc script wasn't fixed.
>
> On Tue, Mar 28, 2017 at 9:23 AM, Lars Volker <lv@cloudera.com> wrote:
>
> > I followed the steps outlined here
> > <https://cwiki.apache.org/confluence/display/IMPALA/
> > Building+native-toolchain+from+scratch+and+using+with+Impala>
> > but when trying to build against my local toolchain I get the error
> below.
> > Does anyone know what I'm doing wrong? Thanks for the help, Lars.
> >
> > CMake Error at CMakeLists.txt:354 (find_package):
> >   Could not find a package configuration file provided by "kuduClient"
> with
> >   any of the following names:
> >
> >     kuduClientConfig.cmake
> >     kuduclient-config.cmake
> >
> >   Add the installation prefix of "kuduClient" to CMAKE_PREFIX_PATH or set
> >   "kuduClient_DIR" to a directory containing one of the above files.  If
> >   "kuduClient" provides a separate development package or SDK, be sure it
> > has
> >   been installed.
> >
> >
> > -- Configuring incomplete, errors occurred!
> > See also "/home/lv/i5/CMakeFiles/CMakeOutput.log".
> > Error in /home/lv/i5/bin/make_impala.sh at line 160: cmake .
> > ${CMAKE_ARGS[@]}
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message