impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Armstrong <tarmstr...@cloudera.com>
Subject Creating branch to build against latest hadoop components
Date Wed, 12 Oct 2016 18:54:27 GMT
I'm working on https://issues.cloudera.org/browse/IMPALA-4277, which
entails building against
Hive 2 and Hadoop 3 and HBase 3. This entails making some small
incompatible changes to the fe Java code to use updated APIs. My first plan
was to try and create compatibility shims, but this looks like it will be
more trouble than it's worth.

So I'm proposing to create a new branch called hadoop-next that will
include any incompatible changes so that we can collaborate on this work. I
think we should keep this branch compilable but initially not worry about
getting tests to pass. I'll also create a gerrit branch for it.

I anticipate that there will only be a small diff between master and this
branch, and I'll periodically merge from master to hadoop-next. Eventually
once we're ready to bump our dependency versions, we can cherry-pick the
changes back to master.

I believe the policy for this is lazy consensus, so I'm going to go ahead
and do it :)

- Tim

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message