impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wang, Youwei A" <youwei.a.w...@intel.com>
Subject RE: Failed to submit/update my patch
Date Fri, 19 Aug 2016 01:03:11 GMT
Greetings, Jim. Yes, the Change-Id I8777cf76f04d34a46f53d53005412e0f1d63b5b7 does appear in
my branch. And it also appears in the cdh5-trunk. As a proof, the following message is copied
from the output of "git log" for cdh5-trunk:

commit 4bc2f0557bce48b04897c0123eba598812931785
Author: Tim Armstrong <tarmstrong@cloudera.com>
Date:   Mon May 23 14:09:39 2016 -0700

    IMPALA-3611: track unused Disk IO buffer memory
    
    Track I/O buffers against separate MemTrackers. This gives us better
    visibility into memory consumption from the debug webpage and from
    MemTracker consumption dumps. The immediate motivation was in trying to
    determine whether idle memory consumption of an impalad was caused by a
    memory leak.
    
    We add two trackers: for buffers cached in DiskIoMgr's free list,
    and another for clients that don't provide a MemTracker (the only
    one is BufferedBlockMgr, which will be removed at some point).
    
    The previous code "tracked" the buffers against the process-wide
    tracker, but it was a no-op outside of ASAN builds since the
    process-wide tracker took its value from TCMalloc.
    
    The test code required fixing because it assumed that buffers were
    always credited against the DiskIoMgr's tracker. This only made sense
    when the DiskIoMgr's tracker is the root process-wide tracker.
    
    Fix backend test logging for disk-io-mgr-test.
    
    Testing:
    Ran exhaustive tests.
    
    Change-Id: I8777cf76f04d34a46f53d53005412e0f1d63b5b7
    Reviewed-on: http://gerrit.cloudera.org:8080/3799
    Reviewed-by: Dan Hecht <dhecht@cloudera.com>
    Tested-by: Internal Jenkins
    (cherry picked from commit 17bf14417e3438d772b19111431453bdd537742a)

PS: And I have conducted some experiments last night:
1. Create an empty VMWare workstation and install Debian 8.5 (the known latest version);
2. Install git; No other unrelated packages are installed;
3. git clone https://github.com/cloudera/Impala.git
4. cd Impala
5. git checkout cdh5-trunk
6. Follow every step from this page:
https://github.com/cloudera/Impala/wiki/Using-Gerrit-to-submit-and-review-patches
7. Apply my patch to cdh5-trunk and then commit it;
8. git push gerrit HEAD:refs/for/cdh5-trunk
Result: I got the exact same error as we discussed.

I have also try to substitute the VMWare workstation using a Debian docker image in the step
1.
And the remained steps are identical. The same error still happens.

-----Original Message-----
From: Jim Apple [mailto:jbapple@cloudera.com] 
Sent: Thursday, August 18, 2016 8:28 PM
To: Wang, Youwei A <youwei.a.wang@intel.com>
Cc: dev@impala.incubator.apache.org
Subject: Re: Failed to submit/update my patch

Does Change-Id: I8777cf76f04d34a46f53d53005412e0f1d63b5b7 show up in your git history when
trying to push? If it does, something is wrong, since this change should not have been merged
into gerrit/cdh5-trunk.

On Thu, Aug 18, 2016 at 12:16 AM, Wang, Youwei A <youwei.a.wang@intel.com> wrote:
> Greetings, everyone.
> Thank you for providing such great solution, @Todd and @Jim.
> But I am afraid I have to say the  'rebase -i' approach doesn't work for me and yes,
I have made 100% sure that my patch is the only patch that show up in my interactive rebase
is my own.
>
> I have also tried another approach: I have diffed my branch and the cdh5-trunk, then
saved it to another place. After that, I switched to the cdh5-trunk, run git pull,  applied
my patch, and then finally commit my changes. Then I run "git push gerrit HEAD:refs/for/cdh5-trunk",
still got the same error. Since now I am working on the latest cdh5-trunk, I believe the possibility
that other branches introduce this error is eliminated. However, this issue still happens.
>
> I am trying to use another clean machine to re-commit my change and check whether that
will happen then.
>
> -----Original Message-----
> From: Todd Lipcon [mailto:todd@cloudera.com]
> Sent: Thursday, August 18, 2016 12:48 PM
> To: Jim Apple <jbapple@cloudera.com>
> Cc: dev@impala <dev@impala.incubator.apache.org>
> Subject: Re: Failed to submit/update my patch
>
> Typically this happens if you've somehow done a rebase such that the upstream patch is
in your branch under a different git hash than was actually committed. I'd recommend fetching
from the upstream branch, doing a 'rebase -i' against it, and making sure that the only patches
that show up in your interactive rebase are your own.
>
> -Todd
>
> On Wed, Aug 17, 2016 at 8:32 PM, Jim Apple <jbapple@cloudera.com> wrote:
>
>> +todd
>>
>> Very strange - I have never seen anything like that.
>>
>> Todd, have you seen anything like this before?
>>
>> On Wed, Aug 17, 2016 at 8:14 PM, Wang, Youwei A 
>> <youwei.a.wang@intel.com>
>> wrote:
>> > Greetings, everyone.
>> > Just two days ago, I could submit/update my patch using following
>> command successfully:
>> > git push gerrit HEAD:refs/for/cdh5-trunk
>> >
>> > However, when I try this command to update my patch at this link today:
>> > https://gerrit.cloudera.org/#/c/3081/
>> >
>> > I have got an error message saying:
>> > ! [remote rejected] HEAD -> refs/for/cdh5-trunk (change
>> http://gerrit.cloudera.org:8080/3246 closed)
>> > error: failed to push some refs to 'ssh://Hayabusa-intel@gerrit.
>> cloudera.org:29418/Impala'
>> >
>> > It seems the push command tried to push my change to another closed
>> change.
>> > That is really weird. Since my local changeId is:
>> > Git log -1
>> > Author: ....................................
>> > Date:   Thu Aug 18 22:53:13 2016 +0800
>> >
>> >     IMPALA-2809: Improve ByteSwap with builtin function or SSSE3 or AVX2.
>> >      ....................................
>> >
>> >     Change-Id: I392ed5a8d5683f30f161282c228c1aedd7b648c1
>> >
>> > The changed from my patch link 
>> > https://gerrit.cloudera.org/#/c/3081/
>> > is
>> also:
>> > Change-Id: I392ed5a8d5683f30f161282c228c1aedd7b648c1
>> > You can see they are identical.
>> >
>> > As for this link http://gerrit.cloudera.org:8080/3246,
>> > Its changeId is I8777cf76f04d34a46f53d53005412e0f1d63b5b7.
>> > Yes, it is closed so the error message (change
>> http://gerrit.cloudera.org:8080/3246 closed) does make some sense here.
>> But I have no idea why git pushes my change to another unrelated change.
>> >
>> > Thank you for any hint or idea.  :)
>> >
>> >
>> >
>>
>
>
>
> --
> Todd Lipcon
> Software Engineer, Cloudera
Mime
View raw message