impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Apple <jbap...@cloudera.com>
Subject HBase errors prevent run-all-tests.sh
Date Mon, 25 Jul 2016 00:12:09 GMT
I'm having trouble with my HBase environment, and it's preventing me
from running bin/run-all-tests.sh. I am on Ubuntu 14.04. I have tried
this with a clean build, and I have tried unset LD_LIBRARY_PATH &&
bin/impala-config.sh, and I have tried ./testdata/bin/run-all.sh

Here is the error I get from compute stats:
(./testdata/bin/compute-table-stats.sh)

Executing: compute stats functional_hbase.alltypessmall
  -> Error: ImpalaBeeswaxException:
 Query aborted:RuntimeException: couldn't retrieve HBase table
(functional_hbase.alltypessmall) info:
Unable to find region for  in functional_hbase.alltypessmall after 35 tries.
CAUSED BY: NoServerForRegionException: Unable to find region for  in
functional_hbase.alltypessmall after 35 tries.

Here is a snippet of the error in ./testdata/bin/split-hbase.sh

Sun Jul 24 15:24:52 PDT 2016,
RpcRetryingCaller{globalStartTime=1469399003900, pause=100,
retries=31}, org.apache.hadoop.hbase.MasterNotRunningException:
com.google.protobuf.ServiceException:
org.apache.hadoop.hbase.ipc.RemoteWithExtrasException(org.apache.hadoop.hbase.ipc.ServerNotRunningYetException):
org.apache.hadoop.hbase.ipc.ServerNotRunningYetException: Server is
not running yet

I tried ./bin/create_testdata.sh, but that exited almost immediately
with no error.

Has anyone else seen and solved this before?

Mime
View raw message