impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Apple <jbap...@cloudera.com>
Subject Re: HBase errors prevent run-all-tests.sh
Date Mon, 25 Jul 2016 00:38:32 GMT
I tried reloading the data with

./bin/load-data.py --workloads functional-query

but that gave errors like

Executing HBase Command: hbase shell
load-functional-query-core-hbase-generated.create
16/07/24 17:19:39 INFO Configuration.deprecation: hadoop.native.lib is
deprecated. Instead, use io.native.lib.available
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in
[jar:file:/opt/Impala-Toolchain/cdh_components/hbase-1.2.0-cdh5.9.0-SNAPSHOT/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in
[jar:file:/opt/Impala-Toolchain/cdh_components/hadoop-2.6.0-cdh5.9.0-SNAPSHOT/share/hadoop/common/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]

ERROR: Can't get the locations

Here is some help for this command:
Start disable of named table:
  hbase> disable 't1'
  hbase> disable 'ns1:t1'

ERROR: Can't get master address from ZooKeeper; znode data == null

On Sun, Jul 24, 2016 at 5:12 PM, Jim Apple <jbapple@cloudera.com> wrote:
> I'm having trouble with my HBase environment, and it's preventing me
> from running bin/run-all-tests.sh. I am on Ubuntu 14.04. I have tried
> this with a clean build, and I have tried unset LD_LIBRARY_PATH &&
> bin/impala-config.sh, and I have tried ./testdata/bin/run-all.sh
>
> Here is the error I get from compute stats:
> (./testdata/bin/compute-table-stats.sh)
>
> Executing: compute stats functional_hbase.alltypessmall
>   -> Error: ImpalaBeeswaxException:
>  Query aborted:RuntimeException: couldn't retrieve HBase table
> (functional_hbase.alltypessmall) info:
> Unable to find region for  in functional_hbase.alltypessmall after 35 tries.
> CAUSED BY: NoServerForRegionException: Unable to find region for  in
> functional_hbase.alltypessmall after 35 tries.
>
> Here is a snippet of the error in ./testdata/bin/split-hbase.sh
>
> Sun Jul 24 15:24:52 PDT 2016,
> RpcRetryingCaller{globalStartTime=1469399003900, pause=100,
> retries=31}, org.apache.hadoop.hbase.MasterNotRunningException:
> com.google.protobuf.ServiceException:
> org.apache.hadoop.hbase.ipc.RemoteWithExtrasException(org.apache.hadoop.hbase.ipc.ServerNotRunningYetException):
> org.apache.hadoop.hbase.ipc.ServerNotRunningYetException: Server is
> not running yet
>
> I tried ./bin/create_testdata.sh, but that exited almost immediately
> with no error.
>
> Has anyone else seen and solved this before?

Mime
View raw message