impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Apple (Code Review)" <ger...@cloudera.org>
Subject [Impala-CR](cdh5-trunk) IMPALA-2878: Remove unused function and duplicate codes.
Date Thu, 16 Jun 2016 01:58:18 GMT
Jim Apple has posted comments on this change.

Change subject: IMPALA-2878: Remove unused function and duplicate codes.
......................................................................


Patch Set 3:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/3311/3/be/src/util/url-coding-test.cc
File be/src/util/url-coding-test.cc:

Line 49: bool Base64Decode(const string& in, string* out) {
> If I choose the first one, it turns back that we should keep Base64Decode f
That's a possible solution.

Please do not copy code and please do not copy the string unnecessarily.


http://gerrit.cloudera.org:8080/#/c/3311/3/be/src/util/url-coding.h
File be/src/util/url-coding.h:

Line 42: bool Base64Length(const int in_len, unsigned* out_max);
> Actually out_max is one more larger than out_len, as comment  in https://ge
Please rename or describe fully this parameter and why it is named the way it is. out_max
does not make sense out of context.


-- 
To view, visit http://gerrit.cloudera.org:8080/3311
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ica8f61fce7af16aa859f71d0763303e8d832ddcd
Gerrit-PatchSet: 3
Gerrit-Project: Impala
Gerrit-Branch: cdh5-trunk
Gerrit-Owner: Yuanhao Luo <luoyuanhao@software.ict.ac.cn>
Gerrit-Reviewer: Jim Apple <jbapple@cloudera.com>
Gerrit-Reviewer: Yuanhao Luo <luoyuanhao@software.ict.ac.cn>
Gerrit-HasComments: Yes

Mime
View raw message