impala-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Jacobs (Code Review)" <ger...@cloudera.org>
Subject [hs2client-CR] Initial structure for the C++ hiveserver2 client.
Date Tue, 10 May 2016 03:23:57 GMT
Matthew Jacobs has posted comments on this change.

Change subject: Initial structure for the C++ hiveserver2 client.
......................................................................


Patch Set 15:

(2 comments)

On second thought, maybe making char/double subclasses of ColumnDesc will be annoying to deal
with. I'm going to think about it a bit more and let's chat tomorrow.

http://gerrit.cloudera.org:8080/#/c/2645/15/src/hs2client/types.h
File src/hs2client/types.h:

Line 40:   int int_value;
       :   std::string string_value;
       : 
       :   // True iff this qualifier represents an int value.
       :   bool is_int;
       :   // True iff this qualifier represents an string value.
       :   bool is_string;
all can be const


Line 107: ColumnDesc
> can you give the parameters better names? Too hard to make sense of like th
Yeah, let's make this a class (consistent with ColumnType) then these can all be private members
and the naming is easy.


-- 
To view, visit http://gerrit.cloudera.org:8080/2645
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I7be82d5897ad6093116915b17924674c4ae508a0
Gerrit-PatchSet: 15
Gerrit-Project: hs2client
Gerrit-Branch: master
Gerrit-Owner: Thomas Tauber-Marshall <tmarshall@cloudera.com>
Gerrit-Reviewer: Marcel Kornacker <marcel@cloudera.com>
Gerrit-Reviewer: Matthew Jacobs <mj@cloudera.com>
Gerrit-Reviewer: Thomas Tauber-Marshall <tmarshall@cloudera.com>
Gerrit-Reviewer: Wes McKinney <wes@cloudera.com>
Gerrit-HasComments: Yes

Mime
View raw message