ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From es70 <eugene.shmu...@gmail.com>
Subject ./control.sh --baseline doesn't list nodes on a linux machines
Date Thu, 13 Sep 2018 11:45:55 GMT
I have a cluster of RHEL machines (3 in total) and run Ignite 2.6 on them.
The nodes seem to see each other since the visor shows them in the TOP
command
<http://apache-ignite-users.70518.x6.nabble.com/file/t2034/visor_-_top.jpg>
so I want to join the nodes to a cluster. I run the ./control.sh --baseline
command on one of the machines to see the list of the available nodes. The
command gives me an empty list. -------------[root@adp-apachelg01 bin]#
./control.sh --baselineControl utility [ver.
2.6.0#20180710-sha1:669feacc]2018 Copyright(C) Apache Software
FoundationUser:
root--------------------------------------------------------------------------------Cluster
state: inactiveCurrent topology version: 4Baseline nodes not
found.----------------The question - what's wrong with it? Please find
attached the config file which I use to start the nodes  cluster-ignite.xml
<http://apache-ignite-users.70518.x6.nabble.com/file/t2034/cluster-ignite.xml>  
cluster-default.xml
<http://apache-ignite-users.70518.x6.nabble.com/file/t2034/cluster-default.xml> 
before running the nodes I ran the service.sh file to amend the firewall
setting  service.sh
<http://apache-ignite-users.70518.x6.nabble.com/file/t2034/service.sh> 
----------------------------Before running Ignite on the linux machines I
did the same on the Windows machines - the ./control.sh --baseline command
gave me the expected listing of the nodes and was able to join them in a
cluster-----------------------One thing to note - I also did the following
thing - I started the visor and a node (with the same config as above) on my
Windows machine. The ./control.sh --baseline command listed me the running
nodes. The visor showed my Windows nodesThen I started my Linux nodes. The
control.sh command stopped to show the nodes. The TOP command in the Visor
showed just my Linus nodes Please advise!!regards,Evgeny



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Mime
View raw message