ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Mekhanikov <dmekhani...@gmail.com>
Subject Re: Different versions in ignite remote and local nodes.
Date Tue, 26 Jun 2018 14:55:45 GMT
Your Kubernetes image and your jar contains different versions of Ignite.

Check logs to see, which one has the version 2.4.0. It's printed at the
startup.

Denis

вт, 26 июн. 2018 г. в 15:51, wadhwasahil <sahil.wadhwa@blackrock.com>:

> I am trying to connect my spark client with ignite cluster version 2.5.0.
> When I run my spark submit job.
>
> **sudo /opt/spark-2.3.0-bin-hadoop2.7/bin/spark-submit --master
> k8s://https://35.192.214.68 --deploy-mode cluster --name sparkIgnite
> --class
> org.blk.igniteSparkResearch.ScalarSharedRDDExample --conf
> spark.executor.instances=3 --conf spark.app.name=sharedSparkIgnite --conf
> spark.kubernetes.authenticate.driver.serviceAccountName=ignite --conf
> spark.kubernetes.container.image=
> us.gcr.io/nlp-research-198620/ignite-spark:v2
>
> local:///opt/spark/jars/igniteSpark-1.0-SNAPSHOT-jar-with-dependencies.jar**
>
> I get the following error.
>
> **class org.apache.ignite.IgniteException: Failed to start manager:
> GridManagerAdapter [enabled=true,
> name=org.apache.ignite.internal.managers.discovery.GridDiscoveryManager*
>
> *Caused by: class org.apache.ignite.spi.IgniteSpiException: Local node and
> remote node have different version numbers (node will not join, Ignite does
> not support rolling updates, so versions must be exactly the same)
> [locBuildVer=2.5.0, rmtBuildVer=2.4.0,
> locNodeAddrs=[ignite-cluster-68787659f9-626k6/0:0:0:0:0:0:0:1%lo,
> /10.8.2.82, /127.0.0.1],
>
> rmtNodeAddrs=[sparkignite-8bad224a0187324ba6f98da08e152c5e-driver/0:0:0:0:0:0:0:1%lo,
> /10.8.2.87, /127.0.0.1], locNodeId=d0c82763-8931-4d66-89ad-2689d8b3d01a,
> rmtNodeId=b6383f55-ecc6-4d5f-acb2-4bd9970d3fc2]*
> *
> The error says that my ignite cluster (local) is using 2.5.0 and my remote
> pod is using 2.4.0. But the ignite I have contains 2.5.0 ignite image, so
> where is the 2.4.0 version coming from?
>
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/
>

Mime
View raw message