ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olexandr K <olexandr.kundire...@gmail.com>
Subject "Connect timed out" errors during cluster restart
Date Tue, 19 Jun 2018 20:22:36 GMT
 Hi Igniters,

I'm getting "connect timed out" errors on each cluster restart
Errors are logged ~10 times before cluster activation
Everything is working fine after that
They are looking as false alarms... looks like nodes are trying to connect
each other when they are not UP yet.
Why it is logged with ERROR level?

I have SSL=on and Authentication=on
Topology: 2 server nodes
Ignite version: 2.5.0
OS: Windows Server 2012 R2

I have custome discovery SPI implementation but it just injects auth
credentials on local node init, nothing more (it extends TcpDiscoverySpi)

Sample error:

2018-06-19 19:43:29.347 [main] ERROR com.xxx.lk.ignite.AuthTcpDiscoverySpi
- Exception on direct send: connect timed out
java.net.SocketTimeoutException: connect timed out
at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method)
~[?:1.8.0_162]
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
~[?:1.8.0_162]
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
~[?:1.8.0_162]
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
~[?:1.8.0_162]
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ~[?:1.8.0_162]
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:1.8.0_162]
at java.net.Socket.connect(Socket.java:589) ~[?:1.8.0_162]
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:673)
~[?:1.8.0_162]
at
org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi.openSocket(TcpDiscoverySpi.java:1450)
~[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi.openSocket(TcpDiscoverySpi.java:1413)
~[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.spi.discovery.tcp.ServerImpl.sendMessageDirectly(ServerImpl.java:1199)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.spi.discovery.tcp.ServerImpl.sendJoinRequestMessage(ServerImpl.java:1046)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.spi.discovery.tcp.ServerImpl.joinTopology(ServerImpl.java:890)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.spi.discovery.tcp.ServerImpl.spiStart(ServerImpl.java:373)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi.spiStart(TcpDiscoverySpi.java:1948)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.internal.managers.GridManagerAdapter.startSpi(GridManagerAdapter.java:297)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.internal.managers.discovery.GridDiscoveryManager.start(GridDiscoveryManager.java:915)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.internal.IgniteKernal.startManager(IgniteKernal.java:1720)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.internal.IgniteKernal.start(IgniteKernal.java:1033)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.internal.IgnitionEx$IgniteNamedInstance.start0(IgnitionEx.java:2014)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.internal.IgnitionEx$IgniteNamedInstance.start(IgnitionEx.java:1723)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.internal.IgnitionEx.start0(IgnitionEx.java:1151)
[ignite-core-2.5.0.jar:2.5.0]
at
org.apache.ignite.internal.IgnitionEx.startConfigurations(IgnitionEx.java:1069)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.internal.IgnitionEx.start(IgnitionEx.java:955)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.internal.IgnitionEx.start(IgnitionEx.java:854)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.internal.IgnitionEx.start(IgnitionEx.java:724)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.internal.IgnitionEx.start(IgnitionEx.java:693)
[ignite-core-2.5.0.jar:2.5.0]
at org.apache.ignite.Ignition.start(Ignition.java:352)
[ignite-core-2.5.0.jar:2.5.0]
at com.xxx.lk.ignite.WindowsService.start(WindowsService.java:45)
[lk.ignite_auth-1.0.0.jar:?]
2018-06-19 19:43:29.362 [main] DEBUG com.xxx.lk.ignite.AuthTcpDiscoverySpi
- Failed to send join request message [addr=v-hp-lk-dcn02.xxxgroup.tek.loc/
10.2.0.252:47502, msg=connect timed out]


[ignite-server.xml]

<property name="discoverySpi">
            <bean class="com.xxx.AuthTcpDiscoverySpi">
<property name="localPort" value="47500"/>
<property name="localPortRange" value="4"/>
                <property name="ipFinder">
                    <bean
class="org.apache.ignite.spi.discovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">

                        <property name="addresses">
                            <list>

<value>v-hp-lk-dcn01.xxxgroup.tek.loc:47500..47504</value>
<value>v-hp-lk-dcn02.xxxgroup.tek.loc:47500..47504</value>
                            </list>
                        </property>
                    </bean>
                </property>
            </bean>
        </property>

BR, Oleksandr

Mime
View raw message