ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mdolgonos <michael.dolgo...@citi.com>
Subject Client node error: org.apache.ignite.internal.processors.query.IgniteSQLException: Failed to initialize DB connection: jdbc:h2:mem...
Date Thu, 26 Apr 2018 19:26:19 GMT
I have a client code that is trying to connect to the remote 3 node cluster.
The code is throwing the following exception:

SEVERE: Failed to reinitialize local partitions (preloading will be
stopped): GridDhtPartitionExchangeId [topVer=AffinityTopologyVersion
[topVer=22, minorTopVer=0], discoEvt=DiscoveryEvent
[evtNode=TcpDiscoveryNode [id=f7898d14-aeab-40be-84be-842978605634,
addrs=[0:0:0:0:0:0:0:1, 10.49.81.242, 127.0.0.1],
sockAddrs=[/0:0:0:0:0:0:0:1:0, /127.0.0.1:0,
<my.machine.address>/10.49.81.242:0], discPort=0, order=22, intOrder=0,
lastExchangeTime=1524769731356, loc=true, ver=2.3.0#20171028-sha1:8add7fd5,
isClient=true], topVer=22, nodeId8=f7898d14, msg=null, type=NODE_JOINED,
tstamp=1524769733797], nodeId=f7898d14, evt=NODE_JOINED]
class org.apache.ignite.internal.processors.query.IgniteSQLException: Failed
to initialize DB connection:
jdbc:h2:mem:f7898d14-aeab-40be-84be-842978605634;LOCK_MODE=3;MULTI_THREADED=1;DB_CLOSE_ON_EXIT=FALSE;DEFAULT_LOCK_TIMEOUT=10000;FUNCTIONS_IN_SCHEMA=true;OPTIMIZE_REUSE_RESULTS=0;QUERY_CACHE_SIZE=0;RECOMPILE_ALWAYS=1;MAX_OPERATION_MEMORY=0;NESTED_JOINS=0;BATCH_JOINS=1;ROW_FACTORY="org.apache.ignite.internal.processors.query.h2.opt.GridH2RowFactory";DEFAULT_TABLE_ENGINE=org.apache.ignite.internal.processors.query.h2.opt.GridH2DefaultTableEngine
.......\Caused by: org.h2.jdbc.JdbcSQLException: Unsupported connection
setting "NESTED_JOINS" [90113-197]

It seems like it is trying to connect to the local H2 database but I don't
understand why.
Here is the relevant section from my configuration file:

	<bean id="ignite.cfg"
class="org.apache.ignite.configuration.IgniteConfiguration">
		<property name="clientMode" value="true" />
		<property name="discoverySpi" ref="ignite.discSpi.tcp" />
		<property name="cacheConfiguration">
			<list>
				<ref bean="ignite.cache.position" />
			</list>
		</property>
	</bean>

	<bean id="ignite.cache.position"
class="org.apache.ignite.configuration.CacheConfiguration">
		<property name="name" value="position" />
		<property name="indexedTypes">
			<list>
				<value>java.lang.Long</value>
				<value>com.xxx.model.Position</value>
			</list>
		</property>
		<property name="atomicityMode" value="ATOMIC" />
		<property name="backups" value="1" />
	</bean>

I also have in my client code the following line;
Ignition.setClientMode(true);

Please advise what I may be missing.
Thanks in advance.




--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/

Mime
View raw message