ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Rodríguez Hortalá <juan.rodriguez.hort...@gmail.com>
Subject ClassNotFoundException when using IgniteHadoopIgfsSecondaryFileSystem
Date Wed, 06 Dec 2017 02:30:30 GMT
Hi,

I'm trying to use IgniteHadoopIgfsSecondaryFileSystem on EMR, and I have
been able to make this work using HDFS in the uri. But when I use a
different scheme for another file system that is working ok with `hadoop
fs` and other applications, I get

```
[hadoop@ip-10-0-0-242 ~]$  hadoop fs -ls
igfs://igfs@ip-10-0-0-85.ec2.internal:10500/
ls: Generic IGFS error occurred.
````

and then in the node ip-10-0-0-85.ec2.internal I see in the logs, at the
same time the request is made, and exception `class
org.apache.ignite.IgniteException: java.lang.ClassNotFoundException` and
`Class not found` for the class implementing Hadoop FileSystem that is
extending org.apache.hadoop.fs.FileSystem that is associated to that scheme
in core-site.xml.

Before I added the path to core-site.xml in configPaths for
CachingHadoopFileSystemFactory I was getting
"org.apache.ignite.IgniteException: No FileSystem for scheme". I have tried
running setup-hadoop.sh  in that slave, and that creates some symlinks, but
I have the same error. The weird thing here is that when I check the node
config with ignite visor I see the jar that contains this class listed
in java.class.path.

Any idea how might I keep debugging this?

Thanks a lot in advance.

Juan

Mime
View raw message