ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Usman Waheed <usmanwaheed...@gmail.com>
Subject Re: Ignite Cluster Error
Date Fri, 29 Dec 2017 08:03:34 GMT
Correction at my end, we increased the timeout's to see if it helps to
resolve our problem but no luck.
So we can set it back to the default settings.

I am also pasting some more settings:

While searching for a resolution, i stumbled upon:
https://issues.apache.org/jira/browse/IGNITE-6555 which i don't think is
related to my problem.


   - <property name="memoryConfiguration">
   <bean class="org.apache.ignite.configuration.MemoryConfiguration">
   <!-- Set the size of default memory region to 4GB. -->
   <property name="defaultMemoryPolicySize" value="# {400L * 1024 * 1024 *
   1024}

   "/>
   </bean>
   </property>
   <property name="communicationSpi">
   <bean
   class="org.apache.ignite.spi.communication.tcp.TcpCommunicationSpi">
   <property name="messageQueueLimit" value="1024"/>
   <property name="slowClientQueueLimit" value="512"/>
   <property name="idleConnectionTimeout" value="3600000"/>
   <property name="sharedMemoryPort" value="-1"/>

</bean>
</property>
<property name="socketTimeout" value="600000"/>
<property name="networkTimeout" value="600000"/>
<property name="joinTimeout" value="600000" />
<property name="ackTimeout" value="50000" />
<property name="statisticsPrintFrequency" value="20000" />

On Fri, Dec 29, 2017 at 12:42 PM, Evgenii Zhuravlev <
e.zhuravlev.wk@gmail.com> wrote:

> Hi,
>
> Why did you set so big timeouts? Why don't default timeouts work for you?
>
> Evgenii
>
> 2017-12-29 10:35 GMT+03:00 Usman Waheed <usmanwaheed556@gmail.com>:
>
>> Hi,
>>
>> We have deployed apache ignite fabric 2.3
>>
>> We get the below error when trying to run on more than 1 node.
>>
>>  GridTimeoutProcessor: Timeout has occurred: CancelableTask
>> [id=970ee7b2061-c1565aa4-510c-4046-9ebb-46efd861b4df,
>> endTime=1512558510454, period=5000, cancel=false,
>> task=org.apache.ignite.internal.processors.cache.query.
>> continuous.CacheContinuousQueryManager$BackupCleaner@2c898c3e]
>>
>>
>>
>> Code is running fine on one node when ever new node joins it is gives
>> above error. We are using the below properties for making the cluster. Any
>> pointers or help will be much appreciated.
>>
>>
>>
>>         <property name="discoverySpi">
>>
>>             <bean class="org.apache.ignite.spi.d
>> iscovery.tcp.TcpDiscoverySpi">
>>
>>                 <property name="socketTimeout" value="600000"/>
>>
>>                 <property name="networkTimeout" value="600000"/>
>>
>>                                 <property name="joinTimeout"
>> value="600000" />
>>
>>                                 <property name="ackTimeout"
>> value="50000" />
>>
>>                                 <property name="statisticsPrintFrequency"
>> value="20000" />
>>
>>
>>
>>                 <property name="ipFinder">
>>
>>                                 <bean class="org.apache.ignite.spi.d
>> iscovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">
>>
>>                        <property name="addresses">
>>
>>                             <list>
>>
>>                 <value>localIP:47500..47509</value>
>>
>>
>>
>>                 <value>remoteIP:47500..47509</value>
>>
>>                             </list>
>>
>>                         </property>
>>
>>                     </bean>
>>
>>                 </property>
>>
>>             </bean>
>>
>>         </property>
>>
>>
>>
>

Mime
View raw message