ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Magda <dma...@apache.org>
Subject Re: getAverageGetTime/getAveragePutTime APIs of CacheMetrics always return 0
Date Thu, 09 Nov 2017 22:49:46 GMT
Hi,

In addition to that you need to enable cache metrics calculation:
To enable cache metrics gathering:
Set CacheConfiguration.setStatisticsEnabled(boolean) to true for every cache you want to collect
the metrics for.
Pass a particular EventStorageSpi interface implementation into IgniteConfiguration.setEventStorageSpi(...)
method. You can use MemoryEventStorageSpi provided out-of-the-box .

Take from here: https://apacheignite.readme.io/v2.3/docs/cache-metrics

In the upcoming releases we plan to simplify cache metrics activation experience:
https://issues.apache.org/jira/browse/IGNITE-5796 <https://issues.apache.org/jira/browse/IGNITE-5796>

—
Denis

> On Nov 8, 2017, at 12:49 AM, headstar <per.johansson@tangotelecom.com> wrote:
> 
> Hi,
> 
> Changed to 2.3.0 and added
> 
>        <property name="dataStorageConfiguration">
>            <bean
> class="org.apache.ignite.configuration.DataStorageConfiguration">
>                <property name="defaultDataRegionConfiguration">
>                    <bean
> class="org.apache.ignite.configuration.DataRegionConfiguration">
>                        <property name="metricsEnabled" value="true"/>
>                    </bean>
>                </property>
>            </bean>
>        </property>
> 
> AverageGetTime/AveragePutTime still 0.
> 
> Per
> 
> 
> 
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/


Mime
View raw message