ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel Tupitsyn <ptupit...@apache.org>
Subject Re: Ignite.NET 2.2 crashes on startup without any information
Date Fri, 29 Sep 2017 15:34:00 GMT
> Error occurred during initialization of VM
> Unable to load native library: Can't find dependent libraries

What is your JAVA_HOME?
Looks like either JAVA_HOME is incorrect, or JRE/JDK install is corrupted.

On Fri, Sep 29, 2017 at 6:33 PM, Patrick Brunmayr <
patrick.brunmayr@kpibench.com> wrote:

> I run my app now from a cmd and this is the output
>
> Error occurred during initialization of VM
> Unable to load native library: Can't find dependent libraries
>
>
>
> Patrick Brunmayr <patrick.brunmayr@kpibench.com> schrieb am Fr. 29. Sep.
> 2017 um 17:30:
>
>> There is no output from visual studio! When i set a break point to
>> Ignition.Start and try to step over it crashes imediately! No output!
>> The only output visual studio gives me is that the app exited with code
>> ox1
>>
>> The output i got was from running the Apache.Ignite.exe directly that was
>> copied to the bin\Debug folder!
>>
>>
>>
>> Alexey Kukushkin <kukushkinalexey@gmail.com> schrieb am Fr. 29. Sep.
>> 2017 um 17:22:
>>
>>> Patrick,
>>>
>>> Is that output from Visual Studio console window? Ignite writes
>>> information to standard output and error and not to the Visual Studio
>>> console. Can you either run your app from cmd.exe or put a breakpoint on
>>> the last line and see output in the cmd.exe that Visual Studio opens?
>>>
>>> On Fri, Sep 29, 2017 at 6:13 PM, Patrick Brunmayr <
>>> patrick.brunmayr@kpibench.com> wrote:
>>>
>>>> I use an embedded version of ignite! Does this help
>>>>
>>>> I got some more details. Launching Ignite.Exe gives me
>>>>
>>>> Error occurred during initialization of VM
>>>>> Unable to load native library: Can't find dependent libraries
>>>>
>>>>
>>>> My JAVA_HOME is properly set to my JDK path
>>>>
>>>> Where should ignite logs reside or how can i activate them ?
>>>>
>>>> Thx
>>>>
>>>>
>>>>
>>>> 2017-09-29 17:09 GMT+02:00 Andrey Mashenkov <andrey.mashenkov@gmail.com
>>>> >:
>>>>
>>>>> Hi Patrick,
>>>>>
>>>>> Would you please share ignite logs?
>>>>>
>>>>> On Fri, Sep 29, 2017 at 5:51 PM, Patrick Brunmayr <
>>>>> patrick.brunmayr@kpibench.com> wrote:
>>>>>
>>>>>> Hello
>>>>>>
>>>>>> I am using Visual Studio 2017 and have installed Apache Ignite via
>>>>>> NuGet. Also checked the VC++ Redis is installed.
>>>>>>
>>>>>> Tried to run this little code
>>>>>>
>>>>>> try
>>>>>> {
>>>>>> var ignite = Ignition.Start();
>>>>>> }
>>>>>> catch (Exception e)
>>>>>> {
>>>>>> Console.WriteLine(e);
>>>>>> }
>>>>>>
>>>>>> My app terminates with following output
>>>>>>
>>>>>>  ConsoleApp1.exe' has exited with code 1 (0x1)
>>>>>>
>>>>>> It just crashes without any information
>>>>>>
>>>>>> My setup
>>>>>>
>>>>>>
>>>>>>    - Windows 10 64 Bit
>>>>>>    - Visual Studio 2017
>>>>>>    - jdk1.8.0_144
>>>>>>    - Ignite 2.2
>>>>>>
>>>>>>
>>>>>> How can i know whats going on without any information. Any ideas
?
>>>>>>
>>>>>> Thx
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Best regards,
>>>>> Andrey V. Mashenkov
>>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Alexey
>>>
>>

Mime
View raw message