ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roger Fischer (CW)" <rfis...@Brocade.com>
Subject RE: Missing object when loading from Cassandra with multiple queries
Date Wed, 02 Aug 2017 20:28:05 GMT
Hello,

it turns out that the problem (missing objects) was caused by cluster configuration issues.
Both the Ignite and Cassandra cluster had one node (not the same VM) configured with a different
time zone. Since date-time was part of the primary key and query parameters, there were inconsistencies
in how the date-time was converted. Because of the combinations of where the queries where
sent and the order in which the results arrived, the outcome appeared to be random.

Caveat: Make sure the clusters are consistent, particularly when date-times are involved.

Roger


-----Original Message-----
From: vkulichenko [mailto:valentin.kulichenko@gmail.com] 
Sent: Friday, July 28, 2017 11:46 AM
To: user@ignite.apache.org
Subject: RE: Missing object when loading from Cassandra with multiple queries

Roger,

Yeah, that's weird and hard to tell why this happens. Obviously there is some kind of race
condition. In any case, I would do everything correctly first, and then check if issue persists
or not.

-Val



--
View this message in context: https://urldefense.proofpoint.com/v2/url?u=http-3A__apache-2Dignite-2Dusers.70518.x6.nabble.com_Missing-2Dobject-2Dwhen-2Dloading-2Dfrom-2DCassandra-2Dwith-2Dmultiple-2Dqueries-2Dtp15644p15789.html&d=DwICAg&c=IL_XqQWOjubgfqINi2jTzg&r=1esZO0r0bYS90lcsaLA6N4AFxuNo6lzauhETGwdJQoQ&m=dl-eqK7P7J3D54eeGL5rjJ10bzaDUx2XL2vaGmM_uIM&s=i9qrKfjX2-aAJAu5beN73PXgRKyHFY6wZpJf5Wlf-zg&e=
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

Mime
View raw message