ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swetad90 <sweta...@gmail.com>
Subject WebConsole 1.9.0 not working
Date Wed, 07 Jun 2017 05:08:16 GMT
Hi,
I am using webconsole 1.9.0 locally.
All of my npm depedencies resolved fine for webconsole/backend and on npm
start gives below output
Start listening on port 3000
Start listening on port 3002

However, for frontend, gulp dependencies are not getting resolved  in
anyway. All the time I am getting below error -
C:\Users\me\Documents\Gridgain\webconsole\apache-ignite-1.9.0-src\apache-ignite-1.9.0-src\modules\web-console\frontend>npm
run dev

> ignite-web-console@1.0.0 dev
> C:\Users\me\Documents\Gridgain\webconsole\apache-ignite-1.9.0-src\apache-ignite-1.9.0-src\modules\web-console\frontend
> cross-env NODE_ENV=development gulp watch

[21:55:26] Failed to load external module babel-register
[21:55:26] Failed to load external module babel-core/register
[21:55:26] Failed to load external module babel/register
C:\Users\me\Documents\Gridgain\webconsole\apache-ignite-1.9.0-src\apache-ignite-1.9.0-src\modules\web-console\frontend\gulpfile.babel.js\index.js:18
import gulp from 'gulp';
^^^^^^
SyntaxError: Unexpected token import
    at createScript (vm.js:56:10)
    at Object.runInThisContext (vm.js:97:10)
    at Module._compile (module.js:542:28)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Liftoff.handleArguments
(C:\Users\me\Documents\Gridgain\webconsole\apache-ignite-1.9.0-src\apache-ignite-1.9.0-src\modules\web-console\frontend\node_modules\gulp\bin\gulp.js:116:3)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! ignite-web-console@1.0.0 dev: `cross-env NODE_ENV=development gulp
watch`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the ignite-web-console@1.0.0 dev script.
npm ERR! This is probably not a problem with npm. There is likely additional
logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!    
C:\Users\me\AppData\Roaming\npm-cache\_logs\2017-06-07T04_55_26_898Z-debug.log


I have tried updating bablerc file, uninstalling-reinstalling gulp,babel,
nothing helps.
Anyone faced such errors?

Node version - 6.10.3
npm version - 5.0.3



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/WebConsole-1-9-0-not-working-tp13451.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

Mime
View raw message