ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Veselovsky <iveselovs...@gridgain.com>
Subject Re: Exception when running hadoop fs -ls igfs://igfs@localhost:10500/
Date Mon, 17 Apr 2017 14:17:08 GMT
It looks like the exception you're observing caused by the following code:
    public ClassReader(final byte[] b, final int off, final int len) {
        this.b = b;
        // checks the class version
        if (readShort(off + 6) > Opcodes.V1_7) {
            throw new IllegalArgumentException();

It means that the class parser encountered a class file compiled using
bytecode version > 1.7 .
Can you please guess such classes in Ignite classpath and try to rebuild
them with 1.7 "target" version?

View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Exception-when-running-hadoop-fs-ls-igfs-igfs-localhost-10500-tp11962p11999.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

View raw message