ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kmandalas <Kyriakos.Manda...@IRIworldwide.com>
Subject Ignite Spring-bean problem
Date Thu, 16 Mar 2017 11:27:20 GMT
Hello,

I am starting an Ignite instance when deploying a Spring application and I
use the IgniteSpringBean in my configuration XML. This node is the "master"
is the one which triggers distributed closures to rest cluster members.

However, when I try to start another "slave" node by command line, I get the
following error:

/Caused by: class org.apache.ignite.spi.IgniteSpiException: Local node and
remote node have different version numbers (node will not join, Ignite does
not support rolling updates, so versions must be exactly the same)/

I have to note that the configuration file at "slave" nodes is similar to
the "master" with the exception that in the "master" node we have the
additional line:

<bean id="igniteSpringBean" class="org.apache.ignite.IgniteSpringBean">
  <property name="configuration" ref="ignite.cfg"></property>
</bean> 



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Ignite-Spring-bean-problem-tp11229.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

Mime
View raw message