ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Riccardo Iacomini <riccardo.iacom...@rdslab.com>
Subject Re: Cassandra basic setup
Date Mon, 28 Nov 2016 16:05:14 GMT
Hi Igor,
I tried your suggestion, but it does find the class. I've also read from
the README files that optional modules must be copied into the libs folder:
same outcome. I've tried also the docker image, adding my configuration xml
files to it, and running the image as specified here
<https://apacheignite.readme.io/v1.5/docs/docker-deployment> in the
documentation. Do you have any other suggestion?

Thanks for your patience.

Best regards

Riccardo Iacomini


*RDSLab*

On Sun, Nov 27, 2016 at 8:46 PM, Igor Rudyak <irudyak@gmail.com> wrote:

> Try to include required jars into IGNITE_LIBS environment variable.
>
> Igor
>
> On Thu, Nov 24, 2016 at 5:21 AM, Riccardo Iacomini <
> riccardo.iacomini@rdslab.com> wrote:
>
>> Hi Igor,
>> thanks for your reply. I've both tried building ignite from source and
>> removing CassandraAdminCredentials class specifying username and password
>> in the bean's properties. Anyway, I cannot get it work. Ignite still cannot
>> find the required classes, this time *org.apache.ignite.cache.store.cassandra.utils.datasource.DataSource.
>> *The class is indeed located in the jar ignite-cassandra-1.7.0.jar in
>> IGNITE_HOME/modules/cassandra/target. I tried adding the path to
>> USER_LIBS and CLASSPATH, no different behavior. Maybe the environment
>> variables got ignored?
>>
>>
>> Riccardo Iacomini
>>
>>
>> *RDSLab*
>>
>> On Wed, Nov 23, 2016 at 7:41 PM, Igor Rudyak <irudyak@gmail.com> wrote:
>>
>>> Hi Riccardo,
>>>
>>> *CassandraAdminCredentials *class is only available in Ignite unit
>>> tests sources. If you want to use it you should build Ignite from source
>>> code. Such way, it will create
>>> *ignite-cassandra-tests-${project.version}.zip* where jar may find jar
>>> file containing all the test classes.
>>>
>>> Also if you want to use Cassandra as a persistent store you actually
>>> don't need *CassandraAdminCredentials  *cause it's just used for tests.
>>>
>>> Igor
>>>
>>> On Wed, Nov 23, 2016 at 7:33 AM, Riccardo Iacomini <
>>> riccardo.iacomini@rdslab.com> wrote:
>>>
>>>> Following the example <https://apacheignite.readme.io/docs/examples>
>>>> provided in the docs, I am trying to setup a basic Ignite cluster using
>>>> Cassandra as persistent store. I've downloaded ignite 1.7 and created the
>>>> configuration files. Ignite does read them at startup, but I get this error
>>>> message:
>>>>
>>>> *class org.apache.ignite.IgniteException: Failed to instantiate Spring
>>>> XML application context (make sure all classes used in Spring configuration
>>>> are present at CLASSPATH*
>>>>
>>>> CassandraAdminCredentials is the class not being found. Commenting the
>>>> bean, I get the same for the next class. I tried adding the path to the jar
*ignite-cassandra-1.7.0.jar
>>>> *to both CLASSPATH and USER_LIBS, still not getting found. Opening the
>>>> jar I cannot find the requested class. Am I missing some dependencies?
>>>>
>>>> Thank you for your help.
>>>>
>>>> Riccardo Iacomini
>>>>
>>>>
>>>> *RDSLab*
>>>>
>>>
>>>
>>
>

Mime
View raw message