ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ranjit <ranj...@amazon.com>
Subject Re: IncompatibleClassChange error in Java/Spark/Ignite program
Date Tue, 16 Aug 2016 17:42:41 GMT
Hi Val,

Really appreciate your responses. 

I did the following things but still see the error:

1. In IntelliJ, removed all dependent JARs
2. Deleted the ~/.m2/repository (local maven repo)
3. Reimported the POM.xml 
4. Ran the program in debug, put breakpoints, inspected that the class
definitions for Spark and Ignite are coming from 2.10

/Users/ranjiti/.m2/repository/org/apache/spark/spark-core_2.10/2.0.0/spark-core_2.10-2.0.0.jar!/org/apache/spark/SparkConf.class

/Users/ranjiti/.m2/repository/org/apache/ignite/ignite-spark_2.10/1.7.0/ignite-spark_2.10-1.7.0.jar!/org/apache/ignite/spark/JavaIgniteContext.class

I'm still seeing the same error :(

16/08/16 10:42:13 INFO BlockManagerMaster: Registered BlockManager
BlockManagerId(driver, 10.44.9.134, 64386)
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/spark/Logging
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/IncompatibleClassChange-error-in-Java-Spark-Ignite-program-tp7053p7107.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

Mime
View raw message