ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vkulichenko <valentin.kuliche...@gmail.com>
Subject Re: Exception during node initialization
Date Tue, 29 Sep 2015 19:32:30 GMT
Hi,

Can you please properly subscribe to the user list so we can get email
notifications? You can refer to these instructions for more info:
http://apache-ignite-users.70518.x6.nabble.com/mailing_list/MailingListOptions.jtp?forum=1


vpasynkova wrote
> I have a client node in my multi-node cluster issuing frequent repeated
> queries against a partitioned cache. If I attempt to add an additional
> node to the cluster while the client is sending these queries, the new
> node fails to start up. The problem is that the client's queries get
> broadcasted to all nodes in the cluster including the new node before the
> new node has had a chance to set up the schema for the partitioned cache
> being queried. The new node logs a "schema not found exception" causing
> the client's query to fail as well. 
> 
> How can I prevent the client from broadcasting the query to this new node
> until its setup is completed?

SQL queries should automatically handle topology changes. Are you using
query API on the client or broadcasting a closure using IgniteCompute? What
version of Ignite are you on?

-Val



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Exception-during-node-initialization-tp1518p1519.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

Mime
View raw message