ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From user604 <jon...@hotmail.com>
Subject AWS/Elastic Beanstalk/Docker
Date Fri, 19 Jun 2015 16:53:49 GMT
I am trying to use Ignite inside clustered docker containers that are
deployed on AWS using Elastic Beanstalk.

I have issues with discovery.  When the container registers itself in the
bucket, I see the IP address is listed as the private address for the docker

I have tried several things, including specifying the instance IP as the
local node address to see if that will work using TcpDiscoverySpi
setLocalAddress, but then it always complains about the port already being
in use.

When starting the docker container, I publish the port with -p 47500:47500,
and also it is exposed.

So far no luck.

I am not a docker expert - so I am hoping there is something simple that I
am missing, because I am sure lots of people would like to run the clustered
Ignite instances in docker containers.

BTW I get the same result if I just run it in docker containers locally. 
The private address gets registered, and if I try and override it, it does
not work either.

Thank you

View this message in context: http://apache-ignite-users.70518.x6.nabble.com/AWS-Elastic-Beanstalk-Docker-tp545.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

View raw message