ignite-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pgarg <pg...@gridgain.com>
Subject Client hang when kill 1 node in 2-node data grid
Date Sat, 09 May 2015 19:33:53 GMT
/asked by jason qian/

Hi Sir/Madam,

We do some POC tests using Apache Ignite. We manually start 2 Ignite nodes
using default "bin/ignite.sh" in one PC. and 2 nodes easily find each other
and I can see the log show "nodes=2" there. Then I start a simple client
which create a PARTITIONED/ATOMIC/FULL_SYNC with 1 backup Cache
(IgniteCache<String, String>), after the client successfully create this
Cache, it starts to Put simple data <"1","1"> <"2","2"> ..<"100000",
"100000"> in a loop. Then I kill 1 node (Ctrl-C) manually during the test.
Then the client just stop and hang there forever. What I expect: since this
is 2-node data grid with the Cache configured having 1 backup, the client
code shall be able continue to Put data even 1 node is dropped from the
2-node data grid.

(I also try the 4-node data grid. And client still hang after just kill 1
node.)

Need help to resolve this client hang issue.

Thanks

----- 
/This post is migrated from now discontinued Apache Ignite forum at 
http://apacheignite.readme.io/v1.0/discuss/



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Client-hang-when-kill-1-node-in-2-node-data-grid-tp278.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

Mime
View raw message