ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gaurav (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-12021) Inserting date from Node.JS to a cache which has Java.SQL.Timestamp
Date Thu, 01 Aug 2019 10:31:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-12021?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16897953#comment-16897953
] 

Gaurav commented on IGNITE-12021:
---------------------------------

Tried that. I didn't work. While doing this I got one more observation. 

I have used putAll and the data passes is array of cache entry. After inserting when I try
to read using cache.Get() , I get Null.

 

If I insert using cache.put(new keyObj(), new valObj()) , I can read it from cache.Get()

 

What am I missing when inserting through cache entry???

 

Thanks,

Gaurav

> Inserting date from Node.JS to a cache which has Java.SQL.Timestamp
> -------------------------------------------------------------------
>
>                 Key: IGNITE-12021
>                 URL: https://issues.apache.org/jira/browse/IGNITE-12021
>             Project: Ignite
>          Issue Type: Bug
>          Components: cache, thin client
>    Affects Versions: 2.7
>         Environment: We are in DEV right now. can't proceed to higher environment with
this show stopper
>            Reporter: Gaurav
>            Priority: Blocker
>              Labels: Node.JS, ignite,
>
> I have cache which has one field with type java.sql.Timestamp
>  
> From, Node.JS i am inserting it as new Date(). 
> If the cache is empty the inserts are successful. Issue come when java inserted few records
in this cache (Java inserts java.sql.Timestamp) . Now , if I run Node.JS program which tries
to insert it gives me this error.
>  
> Binary type has different field types [typeName=XYZCacheName, fieldName=updateTime,
fieldTypeName1=Timestamp, fieldTypeName2=Date]
>  
> Please help, its stopped my work totally!
>  
> P.S : JavaScript new Date() is itself a Timestamp, so cache should ideally accept it
as Timestamp and not Date.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message