ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pankaj Kumar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-11273) IgniteCassandraStoreTestSuite failed under Java 11
Date Mon, 04 Mar 2019 20:01:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-11273?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16783735#comment-16783735
] 

Pankaj Kumar commented on IGNITE-11273:
---------------------------------------

Hello [~dpavlov], I'm not able to reproduce this using maven and also running stand alone
test case in Intellij Idea.

Here is what I have done -
 * Compiled source code using Java 8.
 * set MAVEN_OPTS as (to make it same as TeamCity)
{noformat}
set MAVEN_OPTS=-ea -server -Xmx2g -Xms2g -XX:+HeapDumpOnOutOfMemoryError -XX:+AggressiveOpts
-DIGNITE_UPDATE_NOTIFIER=false -DIGNITE_NO_DISCO_ORDER=true -DIGNITE_PERFORMANCE_SUGGESTIONS_DISABLED=true
-DIGNITE_QUIET=false -Djava.net.preferIPv4Stack=true -DTEST_SCALE_FACTOR=0.1 --illegal-access=permit
--add-exports=java.base/jdk.internal.misc=ALL-UNNAMED --add-exports=java.base/sun.nio.ch=ALL-UNNAMED
--add-exports=java.management/com.sun.jmx.mbeanserver=ALL-UNNAMED --add-exports=jdk.internal.jvmstat/sun.jvmstat.monitor=ALL-UNNAMED
--add-exports=java.base/sun.reflect.generics.reflectiveObjects=ALL-UNNAMED -Djdk.tls.client.protocols=TLSv1.2{noformat}

 * Run mvn test -Dtest=IgniteCassandraStoreTestSuite with maven version 3.6.0 and JDK (open
JDK 11.02)
 * I never get error 'java.lang.ExceptionInInitializerError' and also few of the test cases
passes.
 * I get different error for few of test cases 'Caused by: org.apache.cassandra.io.FSWriteError:
java.nio.file.AccessDeniedException: .\data\commitlog\CommitLog-6-1551728511594.log'

Another approach which I tried was running JUnit test case in IntellijIdea by setting VM option
same as above MAVEN_OPTS.

BTW, I was not able to run test cases using maven profile java-9+ as I was getting invalid
source/target 11 error.

I am running test cases on windows machine. I suspect it could be because of OS (linux) or
Open JDK version.

Could you please confirm if same error comes on windows machine and what is the Open JDK version
used in TeamCity ? 

> IgniteCassandraStoreTestSuite failed under Java 11
> --------------------------------------------------
>
>                 Key: IGNITE-11273
>                 URL: https://issues.apache.org/jira/browse/IGNITE-11273
>             Project: Ignite
>          Issue Type: Bug
>            Reporter: Dmitriy Pavlov
>            Priority: Major
>
> https://ci.ignite.apache.org/viewLog.html?buildId=3027678&buildTypeId=IgniteTests24Java8_CassandraStore
> store.IgniteCassandraStoreTestSuite 	 
> {noformat}
> java.lang.RuntimeException: Failed to start embedded Cassandra instance
> 	at org.apache.ignite.testsuites.cassandra.store.IgniteCassandraStoreTestSuite.setUpClass(IgniteCassandraStoreTestSuite.java:59)
> Caused by: java.lang.ExceptionInInitializerError
> 	at org.apache.ignite.testsuites.cassandra.store.IgniteCassandraStoreTestSuite.setUpClass(IgniteCassandraStoreTestSuite.java:56)
> Caused by: java.lang.StringIndexOutOfBoundsException: begin 0, end -1, length 5
> 	at org.apache.ignite.testsuites.cassandra.store.IgniteCassandraStoreTestSuite.setUpClass(IgniteCassandraStoreTestSuite.java:56)
> {noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message