ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Kalinin (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-11055) Implement operator for handling switch cluster
Date Thu, 24 Jan 2019 07:38:00 GMT
Alexander Kalinin created IGNITE-11055:
------------------------------------------

             Summary: Implement operator for handling switch cluster
                 Key: IGNITE-11055
                 URL: https://issues.apache.org/jira/browse/IGNITE-11055
             Project: Ignite
          Issue Type: Improvement
            Reporter: Alexander Kalinin
            Assignee: Alexander Kalinin


Currently we have a lot of repeated code like this
pipe(
pluck('cluster'),
distinctUntilChanged(),
switchMap((cluster) => {   if (_.isNil(cluster))         return of(EMPTY);   return obs
)
We need to encapsulate it into one operator to use it wherever possible to reduce number of
repetion and improve readability.

 

 

 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message