ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Ozerov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (IGNITE-9777) Gathering local node IO statistics with cache and index dimensions
Date Wed, 21 Nov 2018 09:59:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-9777?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16693201#comment-16693201
] 

Vladimir Ozerov edited comment on IGNITE-9777 at 11/21/18 9:58 AM:
-------------------------------------------------------------------

[~jooger], my comments:
1) IoStatisticsQueryHelper - unused methods, should be removed?
2) IoStatisticsHolderIndex.HASH_PK_IDX_NAME - "PK" as name might be confusing because we also
have PK index in SQL. I would rename it to "HASH_PK" instead.
3) IoStatisticsHolderIndex#toString - why not using S.toString() instead? IoStatisticsHolderCache#toString
- same thing. IoStatisticsHolderQuery - but here we do not have "toString" at all, why?
4) IoStatisticsManager.statsSince - why local and not UTC time?
5) IoStatisticsMetricsMXBean: "getStartGatheringStatistics" -> "getStartTime". Please make
sure that LocalDateTime displayed correctly in JConsole or any other JMX tool
6) IoStatisticsMetricsMXBean: "resetStatistics" -> "reset"
7) IoStatisticsMetricsMXBean: "getCacheStatisticsFormatted" -> "getCacheGroupStatistics",
"getCachePhysicalReadsStatistics" -> "getCacheGroupPhysicalReads", "getCacheLogicalReadsStatistics"
-> "getCacheGroupLogicalReads"
8) Same as p.7 but for indexes.
9) "getStatHashIndexesNames", "getStatSortedIndexesNames", "getStatCachesNames" - I do not
think we need this at all. It is better to simply list available constants in docs.
10) IoStatisticsMetricsMXBean.getCachePhysicalReadsStatistics, getIndexPhysicalReadsStatistics,
getIndexLeafPhysicalReadsStatistics, getIndexInnerPhysicalReadsStatistics -> looks like
these methods are never tested.


was (Author: vozerov):
[~jooger], my comments:
1) IoStatisticsQueryHelper - unused methods, should be removed?
2) IoStatisticsHolderIndex.HASH_PK_IDX_NAME - "PK" as name might be confusing because we also
have PK index in SQL. I would rename it to "HASH_PK" instead.
3) IoStatisticsHolderIndex#toString - why not using S.toString() instead? IoStatisticsHolderCache#toString
- same thing. IoStatisticsHolderQuery - but here we do not have "toString" at all, why?
4) IoStatisticsManager.statsSince - why local and not UTF time?
5) IoStatisticsMetricsMXBean: "getStartGatheringStatistics" -> "getStartTime". Please make
sure that LocalDateTime displayed correctly in JConsole or any other JMX tool
6) IoStatisticsMetricsMXBean: "resetStatistics" -> "reset"
7) IoStatisticsMetricsMXBean: "getCacheStatisticsFormatted" -> "getCacheGroupStatistics",
"getCachePhysicalReadsStatistics" -> "getCacheGroupPhysicalReads", "getCacheLogicalReadsStatistics"
-> "getCacheGroupLogicalReads"
8) Same as p.7 but for indexes.
9) "getStatHashIndexesNames", "getStatSortedIndexesNames", "getStatCachesNames" - I do not
think we need this at all. It is better to simply list available constants in docs.
10) IoStatisticsMetricsMXBean.getCachePhysicalReadsStatistics, getIndexPhysicalReadsStatistics,
getIndexLeafPhysicalReadsStatistics, getIndexInnerPhysicalReadsStatistics -> looks like
these methods are never tested.

> Gathering local node IO statistics with cache and index dimensions
> ------------------------------------------------------------------
>
>                 Key: IGNITE-9777
>                 URL: https://issues.apache.org/jira/browse/IGNITE-9777
>             Project: Ignite
>          Issue Type: Task
>          Components: persistence, sql
>            Reporter: Yury Gerzhedovich
>            Assignee: Yury Gerzhedovich
>            Priority: Major
>              Labels: iep-27
>             Fix For: 2.8
>
>
> Should be gathered and exposed IO statistics on cache/index level.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message