ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Ozerov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-7665) .NET: Target .NET Standard 2.0
Date Thu, 27 Sep 2018 09:16:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-7665?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16630021#comment-16630021
] 

Vladimir Ozerov commented on IGNITE-7665:
-----------------------------------------

Moved to 2.8 due to inactivity. Please feel free to move back if you will be able to complete
the ticket by AI 2.7 code freeze date, September 30, 2018.

> .NET: Target .NET Standard 2.0
> ------------------------------
>
>                 Key: IGNITE-7665
>                 URL: https://issues.apache.org/jira/browse/IGNITE-7665
>             Project: Ignite
>          Issue Type: Improvement
>          Components: platforms
>            Reporter: Pavel Tupitsyn
>            Priority: Major
>              Labels: .NET, xplat
>             Fix For: 2.8
>
>
> As explained in IGNITE-2662 and https://apacheignite-net.readme.io/v2.4/docs/cross-platform-support,
our projects/assemblies still target .NET 4.0.
> This simplifies build/release procedures, but has issues:
> * Ignite.NET *can't be used from .NET Standard 2.0 libraries* (big one)
> * Warning is displayed
> * Incompatible API usages may sneak in despite tests
> We should target {{netstandard2.0}} as well as .NET 4. Release package should contain
two set of assemblies.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message