ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roman Shtykh (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (IGNITE-9253) Rename activation/deactivation commands for REST API
Date Thu, 16 Aug 2018 04:36:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-9253?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16581879#comment-16581879
] 

Roman Shtykh edited comment on IGNITE-9253 at 8/16/18 4:35 AM:
---------------------------------------------------------------

[~kuaw26] [~dpavlov]

Yes, you are right, changing API in a minor version is not good.
 I'll put back "active/inactive" along with "activate/deactivate" and mark them as deprecated.

Please see the changes.


was (Author: roman_s):
[~kuaw26] [~dpavlov]

Yes, you are right, changing API in a minor version is not good.
I'll put back "active/inactive" along with "activate/deactivate" and mark them as deprecated.

> Rename activation/deactivation commands for REST API
> ----------------------------------------------------
>
>                 Key: IGNITE-9253
>                 URL: https://issues.apache.org/jira/browse/IGNITE-9253
>             Project: Ignite
>          Issue Type: Task
>          Components: rest
>            Reporter: Roman Shtykh
>            Assignee: Roman Shtykh
>            Priority: Minor
>
> "Active/inactive" don't sound like commands. I propose to rename to "activate/deactivate."
> It will also bring consistency with the cluster control tool commands (control.sh)
> "response":null can be changed to "activate started"/"deactivate started."



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message