ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitriy Pavlov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IGNITE-9058) Update Apache Tomcat dependency version
Date Thu, 26 Jul 2018 11:32:00 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-9058?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitriy Pavlov updated IGNITE-9058:
-----------------------------------
    Description: 
Update tomcat-servlet-api to newer version (at least 8.0.52,  8.5.31+ or 9.0.9+). E.g. to
{noformat}
<dependency>
    <groupId>org.apache.tomcat</groupId>
    <artifactId>tomcat-servlet-api</artifactId>
    <version>9.0.10</version>
</dependency>
{noformat}

At least Ignite-rest-http, ignite-urideploy, and ignite-web will be affected by this change.

It is required to run TC tartget RunAll to check all tests passed, it is required to build
fabric using DEVNOTES.txt to make sure full build will be successfull

Probably it is required to run release step to make sure release candidate can be prepared.

  was:
Update tomcat-servlet-api to newer version (at least 8.0.52,  8.5.31+ or 9.0.8+)
{noformat}
<dependency>
    <groupId>org.apache.tomcat</groupId>
    <artifactId>tomcat-servlet-api</artifactId>
    <version>8.0.52</version>
</dependency>
{noformat}

At least Ignite-rest-http, ignite-urideploy, and ignite-web will be affected by this change.

It is required to run TC tartget RunAll to check all tests passed, it is required to build
fabric using DEVNOTES.txt to make sure full build will be successfull

Probably it is required to run release step to make sure release candidate can be prepared.


> Update Apache Tomcat dependency version
> ---------------------------------------
>
>                 Key: IGNITE-9058
>                 URL: https://issues.apache.org/jira/browse/IGNITE-9058
>             Project: Ignite
>          Issue Type: Improvement
>            Reporter: Dmitriy Pavlov
>            Assignee: Ivan Fedotov
>            Priority: Major
>             Fix For: 2.7
>
>
> Update tomcat-servlet-api to newer version (at least 8.0.52,  8.5.31+ or 9.0.9+). E.g.
to
> {noformat}
> <dependency>
>     <groupId>org.apache.tomcat</groupId>
>     <artifactId>tomcat-servlet-api</artifactId>
>     <version>9.0.10</version>
> </dependency>
> {noformat}
> At least Ignite-rest-http, ignite-urideploy, and ignite-web will be affected by this
change.
> It is required to run TC tartget RunAll to check all tests passed, it is required to
build fabric using DEVNOTES.txt to make sure full build will be successfull
> Probably it is required to run release step to make sure release candidate can be prepared.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message