ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From José Andrés Peña Villalobos (JIRA) <j...@apache.org>
Subject [jira] [Comment Edited] (IGNITE-8618) Support Java 10
Date Tue, 19 Jun 2018 23:25:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-8618?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16517626#comment-16517626
] 

José Andrés Peña Villalobos edited comment on IGNITE-8618 at 6/19/18 11:24 PM:
-------------------------------------------------------------------------------

I created an question in stackoverflow about the support of Java 10 by Ignite not sure if
this was already addressed: [https://stackoverflow.com/questions/50938116/apache-ignite-2-5-0-java-10-compatibility-on-mac]
  
 I have setup my *JAVA_HOME* environment variable by *$HOME/.profile* this way:

*export JAVA_HOME="$(/usr/libexec/java_home)"*

Downloaded the release *apache-ignite-fabric-2.5.0-bin.zip*

Checking environment:

josepens-mbp:bin josepen$ echo $JAVA_HOME
 */Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home*

josepens-mbp:bin josepen$ $JAVA_HOME/bin/java --version
 *java 10.0.1 2018-04-17*
 *Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)*
 *Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)*

Everything seems fine, however when running bin/.ignite.sh get the following error:

josepens-mbp:bin josepen$ ./ignite.sh
 *./ignite.sh, ERROR: The version of JAVA installed in JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home
is incorrect. Please point JAVA_HOME variable to installation of JDK 1.8 or JDK 9.*
 *You can also download latest JDK at [http://java.com/download]*

Is Ignite compatible with Java 10? Thanks.


was (Author: jose2883cr):
I created an question in stackoverflow about the support of Java 10 by Ignite not sure if
this was already addressed: [https://stackoverflow.com/questions/50938116/apache-ignite-2-5-0-java-10-compatibility-on-mac]
0down vote [favorite|https://stackoverflow.com/questions/50938116/apache-ignite-2-5-0-java-10-compatibility-on-mac]
 
I have setup my *JAVA_HOME* environment variable by *$HOME/.profile* this way:

*export JAVA_HOME="$(/usr/libexec/java_home)"*

Downloaded the release *apache-ignite-fabric-2.5.0-bin.zip*

Checking environment:

josepens-mbp:bin josepen$ echo $JAVA_HOME
*/Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home*

josepens-mbp:bin josepen$ $JAVA_HOME/bin/java --version
*java 10.0.1 2018-04-17*
*Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)*
*Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)*

Everything seems fine, however when running bin/.ignite.sh get the following error:

josepens-mbp:bin josepen$ ./ignite.sh
*./ignite.sh, ERROR: The version of JAVA installed in JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home
is incorrect. Please point JAVA_HOME variable to installation of JDK 1.8 or JDK 9.*
*You can also download latest JDK at [http://java.com/download]*

Is Ignite compatible with Java 10? Thanks.

> Support Java 10
> ---------------
>
>                 Key: IGNITE-8618
>                 URL: https://issues.apache.org/jira/browse/IGNITE-8618
>             Project: Ignite
>          Issue Type: Task
>    Affects Versions: 2.4
>            Reporter: Anghel Botos
>            Priority: Major
>
> Please make required changes so that Ignite runs on Java 10.
> The blocking issue I encontered is related to the usage of Unsafe:
> Caused by: java.lang.RuntimeException: jdk.internal.misc.JavaNioAccess class is unavailable.
>  at org.apache.ignite.internal.util.GridUnsafe.javaNioAccessObject(GridUnsafe.java:1459)
>  at org.apache.ignite.internal.util.GridUnsafe.<clinit>(GridUnsafe.java:118)
>  ... 30 more
> Caused by: java.lang.IllegalAccessException: class org.apache.ignite.internal.util.GridUnsafe
cannot access class jdk.internal.misc.SharedSecrets (in module java.base) because module java.base
does not export jdk.internal.misc to unnamed module @754ba872
>  at java.base/jdk.internal.reflect.Reflection.newIllegalAccessException(Reflection.java:360)
>  at java.base/java.lang.reflect.AccessibleObject.checkAccess(AccessibleObject.java:589)
>  at java.base/java.lang.reflect.Method.invoke(Method.java:556)
>  at org.apache.ignite.internal.util.GridUnsafe.javaNioAccessObject(GridUnsafe.java:1456)
>  ... 31 more
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message