ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitriy Pavlov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IGNITE-6879) Support Spring Data 2.0
Date Tue, 26 Jun 2018 17:51:26 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-6879?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitriy Pavlov updated IGNITE-6879:
-----------------------------------
    Fix Version/s:     (was: 2.6)
                   2.7

> Support Spring Data 2.0
> -----------------------
>
>                 Key: IGNITE-6879
>                 URL: https://issues.apache.org/jira/browse/IGNITE-6879
>             Project: Ignite
>          Issue Type: Improvement
>          Components: spring
>    Affects Versions: 2.3
>            Reporter: Alexey Kukushkin
>            Assignee: Roman Meerson
>            Priority: Major
>             Fix For: 2.7
>
>
> Ignite-spring and ignite-spring-data now use Spring 1.1 and cannot be rebuilt with Spring
2.0. Trying to change the Spring dependency version to 2.0.0.release results in compile errors
like below and requires regression in general. 
> This improvement was created to either migrate from Spring 1.1 to 2.0 or create another
set of modules ignite-spring-xxx-2 to have backward compatibility with Spring 1.1.
> [ERROR] /Users/kukushal/Dev/incubator-ignite/modules/spring-data/src/main/java/org/apache/ignite/springdata/repository/IgniteRepository.java:[57,10]
name clash: deleteAll(java.lang.Iterable<ID>) in org.apache.ignite.springdata.repository.IgniteRepository
and deleteAll(java.lang.Iterable<? extends T>) in org.springframework.data.repository.CrudRepository
have the same erasure, yet neither overrides the other



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message