ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Valentin Kulichenko (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-7284) Introduce DEV_ONLY marker to IgniteLogger
Date Wed, 17 Jan 2018 00:31:01 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-7284?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16328057#comment-16328057

Valentin Kulichenko commented on IGNITE-7284:

[~slukyanov], overall looks good, although here are some minor comments:
 * Let's rename {{warnDev}} to {{warnDevOnly}}.
* System property name should not 'WARNINGS' word in it, as it can be related to other log
levels as well. {{IGNITE_DEV_ONLY_LOGGING_DISABLED}} looks better to me.
* {{IgniteUtils}} should initialize system property value in the static block and then the
value should be reused. It's a bad idea to call {{System.getProperty}} every time, check how
this is done for other properties.
* Marker seems to be nullable. If so, parameter should be marked with {{@Nullable}} in {{IgniteLogger}}

> Introduce DEV_ONLY marker to IgniteLogger
> -----------------------------------------
>                 Key: IGNITE-7284
>                 URL: https://issues.apache.org/jira/browse/IGNITE-7284
>             Project: Ignite
>          Issue Type: Improvement
>          Components: general
>    Affects Versions: 2.3
>            Reporter: Valentin Kulichenko
>            Assignee: Stanislav Lukyanov
>            Priority: Major
>             Fix For: 2.4
> Need to add markers support to {{IgniteLogger}} and then introduce {{DEV_ONLY}} marker
for warnings that can be suppressed in prod environments.
> Problem and solution are discussed in more detail here: http://apache-ignite-developers.2346864.n4.nabble.com/Suppressing-quot-development-quot-warning-td25195.html
> Make sure to update Loggers documentation explaining how the parameter works and what's
it for:
> https://apacheignite.readme.io/docs/logging

This message was sent by Atlassian JIRA

View raw message