ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Kukushkin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-6026) init cluster for Ignite Persistence by xml
Date Fri, 11 Aug 2017 17:19:00 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-6026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16123660#comment-16123660
] 

Alexey Kukushkin commented on IGNITE-6026:
------------------------------------------

Hi Alex,

Please specify "--port 11211" port when running "control.sh --activate". Also, add --host
IGNITE_NODE if you run control.sh on a host where there are no ignite nodes. For example:

./bin/control.sh --host 127.0.0.1 --port 11211 --activate

It looks we have an issue that default Ignite command port is 11211 but control.sh uses 11212
by default.

Let me know if it did not help.

Best regards, Alexey


On Friday, August 11, 2017, 10:36:08 AM GMT+3, Alex Negashev (JIRA) <jira@apache.org>
wrote:


    [ https://issues.apache.org/jira/browse/IGNITE-6026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16122971#comment-16122971
] 

Alex Negashev commented on IGNITE-6026:
---------------------------------------

Hello Alexey, we add client to cluster with config:

        <?xml version="1.0" encoding="UTF-8"?>
        <beans xmlns="http://www.springframework.org/schema/beans" xmlns:cache="http://www.springframework.org/schema/cache"
xmlns:context="http://www.springframework.org/schema/context" xmlns:mvc="http://www.springframework.org/schema/mvc"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="        http://www.springframework.org/schema/beans
        http://www.springframework.org/schema/beans/spring-beans.xsd         http://www.springframework.org/schema/cache
        http://www.springframework.org/schema/cache/spring-cache-3.1.xsd         http://www.springframework.org/schema/context
        http://www.springframework.org/schema/context/spring-context.xsd ">
          <bean class="org.apache.ignite.configuration.IgniteConfiguration">
              <!-- Enable client mdoe. -->
              <property name="clientMode" value="true"/>
              <!-- Enabling Redis. -->
              <property name="connectorConfiguration">
                <bean class="org.apache.ignite.configuration.ConnectorConfiguration">
                    <property name="port" value="6379" />
                </bean>
              </property>

              <!-- Enabling Apache Ignite Persistent Store. -->
              <property name="persistentStoreConfiguration">
                  <bean class="org.apache.ignite.configuration.PersistentStoreConfiguration"/>
              </property>
              <property name="discoverySpi">
                <bean class="org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi">
                    <property name="ipFinder">
                      <bean class="org.apache.ignite.spi.discovery.tcp.ipfinder.zk.TcpDiscoveryZookeeperIpFinder">
                          <property name="allowDuplicateRegistrations" value="false"
/>
                          <property name="basePath" value="/ignite" />
                          <property name="serviceName" value="cache" />
                          <property name="zkConnectionString" value="zk.zookeeper.MY.DISCOVERY.SERVICE:2181"
/>
                      </bean>
                    </property>
                </bean>
              </property>
          </bean>
        </beans>


some logs from instances:
ignite-cache-client-5 | [07:29:53] Topology snapshot [ver=30, servers=5, clients=5, CPUs=40,
heap=10.0GB]
ignite-cache-client-3 | [07:29:53] Topology snapshot [ver=30, servers=5, clients=5, CPUs=40,
heap=10.0GB]
ignite-cache-client-2 | [07:29:53] Topology snapshot [ver=30, servers=5, clients=5, CPUs=40,
heap=10.0GB]

but if i start script `./bin/control.sh --activate` it output: 
root@36ff2f004f78:/opt/ignite/apache-ignite-fabric-2.1.0-bin# ./bin/control.sh --activate
Aug 11, 2017 7:33:59 AM org.apache.ignite.internal.client.impl.GridClientImpl <init>
WARNING: Failed to initialize topology on client start. Will retry in background.
Aug 11, 2017 7:33:59 AM org.apache.ignite.internal.client.impl.GridClientImpl <init>
INFO: Client started [id=6b6279f1-6d5c-46a4-b88a-83d1378d94d2, protocol=TCP]
Something fail during activation, exception message: Latest topology update failed.
Aug 11, 2017 7:33:59 AM org.apache.ignite.internal.client.impl.GridClientImpl stop
INFO: Client stopped [id=6b6279f1-6d5c-46a4-b88a-83d1378d94d2, waitCompletion=true]





--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


> init cluster for Ignite Persistence by xml 
> -------------------------------------------
>
>                 Key: IGNITE-6026
>                 URL: https://issues.apache.org/jira/browse/IGNITE-6026
>             Project: Ignite
>          Issue Type: Wish
>          Components: cache, examples, persistence
>    Affects Versions: 2.1
>         Environment: ignite in docker with zk
>            Reporter: Alex Negashev
>            Assignee: Alexey Kukushkin
>              Labels: documentation
>
> Hello! We use Ignite 2.1 and would like to use Ignite Persistence, how i can do this
without java code? xml only.
> Example attached.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message