ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Ozerov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IGNITE-3527) IGFS: Review "rename", "delete" and "mkdirs" return types in IgniteFileSystem and IgfsSecondaryFileSystem:
Date Mon, 10 Jul 2017 07:08:07 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-3527?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vladimir Ozerov updated IGNITE-3527:
------------------------------------
    Fix Version/s:     (was: 2.1)
                   2.2

> IGFS: Review "rename", "delete" and "mkdirs" return types in IgniteFileSystem and IgfsSecondaryFileSystem:
> ----------------------------------------------------------------------------------------------------------
>
>                 Key: IGNITE-3527
>                 URL: https://issues.apache.org/jira/browse/IGNITE-3527
>             Project: Ignite
>          Issue Type: Task
>          Components: igfs
>    Affects Versions: 1.6
>            Reporter: Vladimir Ozerov
>             Fix For: 2.2
>
>
> Currently their semantics are not clear:
> - boolean delete()
> - void mkdirs()
> - void rename();
> They all must have the same return type and semantics. The question is which semantics
to choose:
> 1) Return boolean and (almost) never throw exceptions. This is "JDK way". I personally
do not like it because user will have to both check for true/false and use try/catch.
> 2) Return void and throw exception if something went wrong. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message