ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Mashenkov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (IGNITE-3562) Dependency to outdated Lucene 3.5.0
Date Tue, 23 May 2017 15:28:04 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-3562?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16021299#comment-16021299
] 

Andrew Mashenkov edited comment on IGNITE-3562 at 5/23/17 3:27 PM:
-------------------------------------------------------------------

Tests looks good after upgrade to 4.10.4.

Upgrading to latest Lucene version 5.5.2 seems to be much easy 
if it made in 2 steps: 3.5.0 -> 4.x -> 5.x 



was (Author: amashenkov):
Tests looks good after upgrade to 4.10.4.

Upgrading to latest Lucene version 6.5.1 seems to be much easy 
if it made in 3 steps: 3.5.0 -> 4.x -> 5.x -> latest 6.x.

Waiting for TC test for Lucene 6.5.1.


> Dependency to outdated Lucene 3.5.0
> -----------------------------------
>
>                 Key: IGNITE-3562
>                 URL: https://issues.apache.org/jira/browse/IGNITE-3562
>             Project: Ignite
>          Issue Type: Bug
>          Components: general
>    Affects Versions: 1.6
>            Reporter: Alexander Veit
>            Assignee: Andrew Mashenkov
>              Labels: jar-hell
>             Fix For: 2.1
>
>
> Ignite 1.6.0 comes with Lucene 3.5.0 core as dependency, which dates back to the year
2011.
> This makes it difficult to integrate with newer software.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message