ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrey Gura (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-4587) Discontinue and remove CacheAtomicWriteOrderMode.CLOCK mode
Date Mon, 13 Mar 2017 17:37:41 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-4587?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15907918#comment-15907918
] 

Andrey Gura commented on IGNITE-4587:
-------------------------------------

[~dreamx],

I've review your changes. See my comments below. Please, fix.

# Class {{GridCacheAtomicFullApiSelfTest}}: method {{cacheConfiguration()}} can be removed
because it just returns result of base class method.
# Class {{GridCacheAtomicMultiNodeP2PDisabledFullApiSelfTest}}: method {{cacheConfiguration()}}
can be removed because it just returns result of base class method.
# Class {{GridCacheReplicatedAtomicMultiNodeFullApiSelfTest}}: method {{cacheConfiguration()}}
can be removed because it just returns result of base class method.
# Class {{GridCacheAtomicMessageCountSelfTest}}: methods {{testPartitionedPrimary()}} and
{{testClientPrimary()}} should be renamed to {{testPartitioned()}} and {{testClient()}} respectively.
# Class {{GridCacheAtomicNearCacheSelfTest}}: method {{startGridsLocal()}} confuses. Why {{Local}}?
May be {{doStartGrids}} or something like.
# Class {{GridCacheAtomicVersionComparator}}: {{ignoreTime}} parameter at {{compare}} method
is unused and should be removed.
# Class {{GridCacheInterceptorAbstractSelfTest}}: unused import and methods.
# Class {{GridCacheMapEntry}}, method {{innerUpdate}}, lines 2172 and 2228: {{ignireTime}}
variable is always {{true}}. Need remove usage.
# Class {{GridCacheMultithreadedFailoverAbstractTest}}, method {{configuration()}}, line 221:
Nested if could be combined with embraced.
# Class {{GridCacheUtils}}: unused imports.
# Class {{GridCacheUtils}}: Bug. Please fix array size and offsets in {{versionToBytes()}}
and {{readVersion()}} methods.
# Class {{IgniteUtils}}: Bug. Please fix offsets in {{writeVersion()}} and {{readVersion()}}
methods.
# Class {{GridCacheVersion}}: Bug. Integers will be overflowed in {{asGridUuid()}} method.
Please replace by {{new UUID(topVer, nodeOrderDrId)}}.
# Class {{GridCacheVersion}}: method {{fieldsCount()}} returns incorrect result. Use {{MessageCodeGenerator}}
in order to generate correct code.
# Class {{GridCacheVersionEx}}: incorrect implementations of {{fieldsCount()}}, {{writeTo()}}
and {{readFrom()}} methods. Use {{MessageCodeGenerator}} in order to generate correct code.
# Class {{GridCommonAbstractTest}}: unused imports.
# Class {{GridCommonAbstractTest}}: method {{atomicClockModeDelay()}} should be removed.
# Class {{GridDhtAtomicCache}}: I'm not sure about it. It seems that methos {{isFastMap()}}
should not be removed. Could you please ask about it on dev list. Check also {{fastMap}} flag
in {{GridNearAtomicUpdateFuture}} class.
# Class {{GridDhtAtomicCache}}: Redundant {{catch}} blocks in {{lockEntriesMethod()}}, lines
2899 and 2914.
# Class {{GridNearAtomicSingleUpdateFuture}}: Method {{mapSingleUpdate()}} creates different
requests (like {{GridNearAtomicSingleUpdateInvokeRequest}}). For all this requests all instantiations
have {{updateVer == null}}. Need to remove this prameter. The same for {{GridNearAtomicUpdateFuture}}
class {{mapUpdate()}} and {{mapSingleUpdate()}} methods.
# Class {{IgniteBenchmarkArguments}}: Comand line arguments {{"-wom", "--writeOrderMode"}}
were removed. Please, check that there are not this arguments usges in {{modules/yardstick}}.
# Class {{IgniteCacheExpiryPolicyAbstractTest}}: methods {{nearReaderUpdate()}} and {{nearPutAll()}}.
It seems that all {{U.sleep()}} calls are redundant now.
# Class {{IgniteCachePutRetryAbstractSelfTest}}: unused import.

Also I see a lot of removed tests. I need additional time for analyzing it. Thanks!

> Discontinue and remove CacheAtomicWriteOrderMode.CLOCK mode
> -----------------------------------------------------------
>
>                 Key: IGNITE-4587
>                 URL: https://issues.apache.org/jira/browse/IGNITE-4587
>             Project: Ignite
>          Issue Type: Bug
>          Components: cache
>            Reporter: Denis Magda
>            Assignee: Maksim Kozlov
>             Fix For: 2.0
>
>
> {{CacheAtomicWriteOrderMode.CLOCK}} proved to be harmful in production due to timing
issues.
> It makes sense to remove it completely in 2.0 release. Migration guide has be updated:
> https://cwiki.apache.org/confluence/display/IGNITE/Apache+Ignite+2.0+Migration+Guide



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message