ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Denis Magda (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IGNITE-1794) Ignite should support Hibernate 5
Date Fri, 20 Jan 2017 21:02:26 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-1794?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Denis Magda updated IGNITE-1794:
--------------------------------
    Fix Version/s: 1.9

> Ignite should support Hibernate 5
> ---------------------------------
>
>                 Key: IGNITE-1794
>                 URL: https://issues.apache.org/jira/browse/IGNITE-1794
>             Project: Ignite
>          Issue Type: Test
>            Reporter: Artem Shutak
>            Assignee: Mykola Pereyma
>              Labels: newbie
>             Fix For: 1.9
>
>         Attachments: HibernateCollectionRegionForIgnite.java, HibernateEntityRegionForIgnite.java,
HibernateRegionFactoryForIgnite.java, HibernateTimestampsRegionForIgnite.java
>
>
> Currently Ignite supports Hibernate 4. 
> In Hibernate 5 org.hibernate.cache.spi.RegionFactory.start() method signature has been
changed from
> {{void start(Settings var1, Properties var2) throws CacheException;}}
> on
> {{void start(SessionFactoryOptions settings, Properties properties) throws CacheException;}}
> Original user list: http://apache-ignite-users.70518.x6.nabble.com/Hibernate-5-L2-Cache-Compatibility-td1656.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message