ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Valentin Kulichenko (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-1794) Ignite should support Hibernate 5
Date Thu, 19 Jan 2017 01:15:26 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-1794?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15829111#comment-15829111
] 

Valentin Kulichenko commented on IGNITE-1794:
---------------------------------------------

It looks like this change is not backward compatible and moreover completely drops support
for Hibernate 4. [~mpereyma], can you please confirm this? If so, I think we should create
two separate modules for Hibernate 4 and 5 to support both.

> Ignite should support Hibernate 5
> ---------------------------------
>
>                 Key: IGNITE-1794
>                 URL: https://issues.apache.org/jira/browse/IGNITE-1794
>             Project: Ignite
>          Issue Type: Test
>            Reporter: Artem Shutak
>            Assignee: Mykola Pereyma
>              Labels: newbie
>         Attachments: HibernateCollectionRegionForIgnite.java, HibernateEntityRegionForIgnite.java,
HibernateRegionFactoryForIgnite.java, HibernateTimestampsRegionForIgnite.java
>
>
> Currently Ignite supports Hibernate 4. 
> In Hibernate 5 org.hibernate.cache.spi.RegionFactory.start() method signature has been
changed from
> {{void start(Settings var1, Properties var2) throws CacheException;}}
> on
> {{void start(SessionFactoryOptions settings, Properties properties) throws CacheException;}}
> Original user list: http://apache-ignite-users.70518.x6.nabble.com/Hibernate-5-L2-Cache-Compatibility-td1656.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message