ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Mashenkov (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-4424) REPLICATED cache isn't synced across nodes
Date Tue, 13 Dec 2016 15:44:58 GMT
Andrew Mashenkov created IGNITE-4424:
----------------------------------------

             Summary: REPLICATED cache isn't synced across nodes
                 Key: IGNITE-4424
                 URL: https://issues.apache.org/jira/browse/IGNITE-4424
             Project: Ignite
          Issue Type: Bug
          Components: cache
            Reporter: Andrew Mashenkov
            Priority: Critical
             Fix For: 2.0


Replicated cache sometimes won't sync across nodes properly.
Cache should be configured with CacheWriteSynchronizationMode.FULL_SYNC and CacheRebalanceMode.SYNC
PFA a reproducer code.

All nodes are started at the same time on different machines:
* Ignition.start() // Blocks until node is up
* Only one of the nodes performs next: getOrCreateCache() then putAll() 
* All the other nodes block on this before proceeding. 
* All of the nodes perform next:
** getOrCreateCache() // Again
** cache.localSize(CachePeekMode.ALL)
All nodes should see filled cache, but sometimes some nodes see empty cache. LocalSize call
can be replaced by iterating over cache, but result will be same.

Logs says that more than one cluster is started unexpectedly, but there is no errors at all.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message