ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Chugunov (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-4209) Semaphore gets broken when one of nodes finishes normally and leaves topology
Date Thu, 10 Nov 2016 12:42:58 GMT
Sergey Chugunov created IGNITE-4209:
---------------------------------------

             Summary: Semaphore gets broken when one of nodes finishes normally and leaves
topology
                 Key: IGNITE-4209
                 URL: https://issues.apache.org/jira/browse/IGNITE-4209
             Project: Ignite
          Issue Type: Bug
            Reporter: Sergey Chugunov


h4. Notes
Bug is reproducible with latest version of code available in master branch.

As [~vladisav] suggested (see link to mailing list below) root cause of the bug may be that
current implementation handles EVT_NODE_LEFT and EVT_NODE_FAILED events in the same way and
puts semaphore to a broken state.

h4. Steps to reproduce
# Using *ExampleNodeStartup* class start two or more server nodes.
# Using *IgniteSemaphoreExample* class run example and let it finish (it should finish normally
and then terminate).
# Run *IgniteSemaphoreExample* once again.

h4. Expected behavior
Second execution of the same example finishes successfully.
h4. Actual behavior
Second execution hangs forever, node running example never finishes.

Developers mailing list discussion: [semaphore unexpected behavior|http://apache-ignite-developers.2346864.n4.nabble.com/IGNITE-4155-IgniteSemaphoreExample-unexpected-behavior-td12077.html].





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message