ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "C Saternos (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-4176) IgniteQueue not functioning as expected after remove().
Date Thu, 03 Nov 2016 19:16:58 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-4176?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15633909#comment-15633909
] 

C Saternos commented on IGNITE-4176:
------------------------------------

BTW - apologies if this is not contributed correctly.  I have not participated in Apache open
source projects before, but I thought the problem was significant enough to warrant your attention.
 No offense intended.

> IgniteQueue not functioning as expected after remove().
> -------------------------------------------------------
>
>                 Key: IGNITE-4176
>                 URL: https://issues.apache.org/jira/browse/IGNITE-4176
>             Project: Ignite
>          Issue Type: Bug
>          Components: data structures
>    Affects Versions: 1.7
>            Reporter: C Saternos
>         Attachments: WhereDidItGo.java, pom.xml
>
>
> After removing an item from an IgniteQueue, the next item on the queue can be viewed
using peek().  However, poll() or take() does not retrieve the item.  When iterating through
the remaining items in the queue, it appears that 1/2 of them are missing.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message