ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Man (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IGNITE-3984) NullPointerException in IgniteCacheProxy when creating continuous query
Date Wed, 28 Sep 2016 01:47:20 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-3984?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jason Man updated IGNITE-3984:
------------------------------
    Attachment: ContQueryTest.java

> NullPointerException in IgniteCacheProxy when creating continuous query
> -----------------------------------------------------------------------
>
>                 Key: IGNITE-3984
>                 URL: https://issues.apache.org/jira/browse/IGNITE-3984
>             Project: Ignite
>          Issue Type: Bug
>          Components: cache
>    Affects Versions: 1.7
>            Reporter: Jason Man
>         Attachments: ContQueryTest.java
>
>
> Test attached.  This used to work fine in 1.6.  This seem to be related to this jira
and PR:
> https://issues.apache.org/jira/browse/IGNITE-3413
> https://github.com/apache/ignite/commit/89d64e74b697054a88c3a91433aaaf4f7fdd0284
> Here's the scenario:
> * First node starts with special attribute and creates a cache with the node filter that
allows to deploy it only on nodes with this attribute
> * Second node starts without the attribute is started.  When creating a continuous query
to query the cache created by the first node, a NullPointerException is thrown.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message