ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandre Boudnik (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-1560) ClassNotFoundException on AWS
Date Tue, 29 Sep 2015 00:59:04 GMT
Alexandre Boudnik created IGNITE-1560:
-----------------------------------------

             Summary: ClassNotFoundException on AWS
                 Key: IGNITE-1560
                 URL: https://issues.apache.org/jira/browse/IGNITE-1560
             Project: Ignite
          Issue Type: Bug
          Components: general
    Affects Versions: ignite-1.4
         Environment: AWS
            Reporter: Alexandre Boudnik
            Priority: Critical


Optional ignite-aws has outdated (2012) dependency:

    <dependency>
      <groupId>com.amazonaws</groupId>
      <artifactId>aws-java-sdk</artifactId>
      <version>1.3.21.1</version>
      <scope>compile</scope>
    </dependency>

that depends on

        <dependency>
            <groupId>org.codehaus.jackson</groupId>
            <artifactId>jackson-core-asl</artifactId>
            <version>1.8.9</version>
            <type>jar</type>
            <scope>compile</scope>
        </dependency>
        <dependency>
            <groupId>org.codehaus.jackson</groupId>
            <artifactId>jackson-mapper-asl</artifactId>
            <version>1.8.9</version>
            <type>jar</type>
            <scope>compile</scope>
        </dependency>

As results it produces ClassNotFoundException for org.codehaus.jackson.JsonNode and org.codehaus.jackson.map.ObjectMapper
classes

I would recommend to switch to newer version of aws-java-sdk, which is has no external dependencies.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message